Bug 796966 - The serial port is not open LCP terminated by peer
The serial port is not open LCP terminated by peer
Status: CLOSED DUPLICATE of bug 798231
Product: Fedora
Classification: Fedora
Component: ModemManager (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-23 18:19 EST by dev002
Modified: 2012-07-27 11:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-27 11:04:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dev002 2012-02-23 18:19:12 EST
Description of problem:
The serial port is not open after LCP terminated by peer

Version-Release number of selected component (if applicable):


How reproducible:
Plug Bandluxe c339 HSPA+,Bus 001 Device 006: ID 1a8d:2006 BandRich, Inc., Icera based with ttyACM0, ttyACM1, and ethernet port.

Steps to Reproduce:
1. Plug and connect
2. Peer disconnect
3. Modem port unavaliable any more 
4. replug usb...
  
Actual results:
bad manage of peer actions

Expected results:
reconnect and work

Additional info:

NetworkManager[668]: rcvd [LCP TermReq id=0x0 "0024: Normal Termination by NCP"]
pppd[1340]: LCP terminated by peer (0024: Normal Termination by NCP)
NetworkManager[668]: LCP terminated by peer (0024: Normal Termination by NCP)
NetworkManager[668]: ** Message: nm-ppp-plugin: (nm_phasechange): status 8 / phase 'network'
pppd[1340]: Connect time 231.9 minutes.
NetworkManager[668]: Connect time 231.9 minutes.
pppd[1340]: Sent 31111034 bytes, received 283709133 bytes.
NetworkManager[668]: Sent 31111034 bytes, received 283709133 bytes.
NetworkManager[668]: Script /etc/ppp/ip-down started (pid 6834)
NetworkManager[668]: ** Message: nm-ppp-plugin: (nm_phasechange): status 5 / phase 'establish'
NetworkManager[668]: sent [LCP TermAck id=0x0]
pppd[1340]: Modem hangup
...
NetworkManager[668]: <info> disconnect failed: (32) The serial port is not open.
...
[nm-device-ethernet.c:752] real_update_permanent_hw_address(): (eth2): unable to read permanent MAC address (error 0)
1330022965.941457] [nm-device-ethernet.c:752] real_update_permanent_hw_address(): (eth2): unable to read permanent MAC address (error 0)
nager[668]: <info> (eth2): carrier is OFF

....
cdc_acm 1-8.4.1...: ttyACM0: USB ACM device
cdc_acm 1-8.4.1...: ttyACM1: USB ACM device
usbcore: registered new interface driver cdc_acm
cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
cdc_ether 1-8.4.1... eth2: register 'cdc_ether' at usb-0000:00:10.4-8.4.1..., CDC Ethernet Device, <MAC>
usbcore: registered new interface driver cdc_ether
Comment 1 Dan Williams 2012-07-27 11:04:05 EDT

*** This bug has been marked as a duplicate of bug 798231 ***

Note You need to log in before you can comment on or make changes to this bug.