Bug 797032 - [whql][virtio-scsi] Storage Query Property job failed due to " 0 is an invalid value for SerialNumberOffset. "
[whql][virtio-scsi] Storage Query Property job failed due to " 0 is an invali...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-24 00:45 EST by Mike Cao
Modified: 2014-07-11 02:46 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:38:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Cao 2012-02-24 00:45:22 EST
Description of problem:


Version-Release number of selected component (if applicable):
virtio-win-prewhql-23
win2k8R2 

How reproducible:
100%

Steps to Reproduce:
1.start virtio scsi whql test 
2.run Storage Query Property(LOGO) job
  
Actual results:
job failed due to " 0 is an invalid value for SerialNumberOffset"

Expected results:
job pass


Additional info:
Comment 1 Mike Cao 2012-02-24 00:47:36 EST
Created attachment 565501 [details]
DTM log
Comment 3 Ronen Hod 2012-03-06 04:21:51 EST
Moving all SCSI to 6.4
Comment 5 RHEL Product and Program Management 2012-07-10 03:03:24 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2012-07-10 22:03:15 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 8 Mike Cao 2012-07-17 02:59:54 EDT
QE run new around scsi whql test on virtio-win-prewhql-29 ,does not hit this issue ,
This issue has been fixed ald 
Will change bug status if the job will pass in the next round
Comment 9 Mike Cao 2012-08-02 23:06:07 EDT
According to comment #8, move status to verified.
Comment 10 Mike Cao 2012-12-10 02:16:46 EST
Reproduce this issue on build 49
Need to mention that We did not reproduce this on build 45

Based on above ,re-assign this bug and add regression flag
Comment 13 Mike Cao 2012-12-10 04:08:19 EST
(In reply to comment #12)
> Hi Mike,
> There were no changes in scsi between 45 and 49 somehow related to this
> issue.
> Could you please post the most recent cpk file, qemu command line and qemu
> version?
> 
#2.6.32-338.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.331.el6.x86_64
virtio-win-prewhql-49

CLI:usr/libexec/qemu-kvm -m 6G -smp 4 -cpu cpu64-rhel6,+x2apic,family=0xf -usb -device usb-tablet -device virtio-scsi-pci,id=scsi0 -drive file=win2k8-R2-SCSI-49.raw,format=raw,if=none,id=drive-virtio0,cache=none,werror=stop,rerror=stop -device scsi-hd,bus=scsi0.0,drive=drive-virtio0,id=virtio-blk-pci0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet0,mac=00:52:47:11:31:46 -uuid 0ccc9ba0-b793-4252-bd71-a366e3de6f94 -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-winR2-scsi,server,nowait -mon chardev=111a,mode=readline -vnc :1 -rtc base=localtime,clock=host,driftfix=slew -chardev socket,id=seabios_debug,path=/tmp/monitor-seabios,server,nowait -device isa-debugcon,iobase=0x402,chardev=seabios_debug -device virtio-scsi-pci,id=scsi1 -drive file=disk1.raw,if=none,format=raw,cache=none,id=drive-virtio-data1,werror=stop,rerror=stop -device scsi-hd,bus=scsi1.0,id=virtio-data1,drive=drive-virtio-data1 -device virtio-scsi-pci,id=scsi2 -drive file=disk2.raw,if=none,cache=none,format=raw,id=drive-virtio-data2,werror=stop,rerror=stop -device scsi-hd,bus=scsi2.0,id=virtio-data2,drive=drive-virtio-data2 -device virtio-scsi-pci,id=scsi3 -drive file=disk3.raw,cache=none,if=none,format=raw,id=drive-virtio-data3,werror=stop,rerror=stop -device scsi-hd,bus=scsi3.0,id=virtio-data3,drive=drive-virtio-data3 -device virtio-scsi-pci,id=scsi4 -drive file=disk4.raw,if=none,format=raw,cache=none,id=drive-virtio-data4,werror=stop,rerror=stop -device scsi-hd,bus=scsi4.0,id=virtio-data4,drive=drive-virtio-data4 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -M rhel6.4.0
> Thank you,
> Vadim.
Comment 14 Mike Cao 2012-12-10 04:17:55 EST
Created attachment 660640 [details]
Bug797032_failed_CPK
Comment 15 Vadim Rozenfeld 2012-12-10 15:21:52 EST
Hi Mike,
Could you please try adding adding serial names parameter to all drives?
Thank you,
Vadim.
Comment 16 Mike Cao 2012-12-11 01:10:18 EST
(In reply to comment #15)
> Hi Mike,
> Could you please try adding adding serial names parameter to all drives?
> Thank you,
> Vadim.

Works ,Sorry for my mistake ,move back to verified

Mike
Comment 17 errata-xmlrpc 2013-02-21 05:38:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0441.html

Note You need to log in before you can comment on or make changes to this bug.