Bug 797108 - DNS server changed unexpectedly even without change on the TUI
DNS server changed unexpectedly even without change on the TUI
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: TestOnly
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-24 04:48 EST by shine
Modified: 2016-04-26 10:17 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When configuring the Hypervisor to use DHCP, previously configured DNS server entries would be wiped out. Now, the previously configured servers are kept.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 10:19:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description shine 2012-02-24 04:48:52 EST
Description of problem:
DNS server changed unexpectedly.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120215.0.el6

How reproducible:
100%

Steps to Reproduce:
1. Configure eth0 with dhcp, DNS server is blank, use arrow keys switch to "status" page and back to "network",it's 10.66.127.10 now. (bug 746180)
2. Change DNS server to 10.66.104.210 and apply, it still show 10.66.127.10 both in tui and /etc/resolv.conf.
3. Change DNS server to 10.66.104.210 again and apply, it is 10.66.104.210 both in tui and /etc/resolv.conf.
4. Configure the eth0 with dhcp again, DNS server displayed 10.66.104.210, but in /etc/resolv.conf it's 10.66.127.10, use arrow keys switch to "status" page and back to "network", it's 10.66.127.10. (bug 746180)
5. Do not change anything and apply on the network page. the DNS server changed from 10.66.127.10 to 10.66.104.210.
6. Do not change anything and apply on the network page. The DNS server changed from 10.66.104.210 to 10.66.127.10
7. repeat press the apply button, dns server is altering between them.
  
Actual results:
DNS server changed unexpectedly after some configure actions.

Expected results:
DNS server should not change if user does not change it on TUI.
Comment 3 Guohua Ouyang 2012-04-16 22:53:03 EDT
verified on 6.3-20120411.1 build, the DNS server always displayed what you have changed.

move the bug to status "verified".
Comment 4 Mike Burns 2012-06-13 12:54:35 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When using DHCP, a previously configured DNS server would be wiped out.  Now, the previously configured server is honored and kept correctly.
Comment 5 Stephen Gordon 2012-06-13 17:52:55 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-When using DHCP, a previously configured DNS server would be wiped out.  Now, the previously configured server is honored and kept correctly.+When configuring the Hypervisor to use DHCP, previously configured DNS server entries would be wiped out. Now, the previously configured servers are kept.
Comment 7 errata-xmlrpc 2012-07-19 10:19:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0741.html

Note You need to log in before you can comment on or make changes to this bug.