Bug 798010 - [abrt] virt-manager-0.9.1-2.fc16: libusb_set_debug: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
[abrt] virt-manager-0.9.1-2.fc16: libusb_set_debug: Process /usr/bin/python w...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: spice-gtk (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
abrt_hash:9f2c2f501625f66cc7c61e6ff11...
:
: 801098 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-27 15:05 EST by Stanislav Petr
Modified: 2012-04-11 12:55 EDT (History)
13 users (show)

See Also:
Fixed In Version: libusb1-1.0.9-0.6.rc1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-11 12:55:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (17.28 KB, text/plain)
2012-02-27 15:05 EST, Stanislav Petr
no flags Details
File: maps (75.68 KB, text/plain)
2012-02-27 15:05 EST, Stanislav Petr
no flags Details
File: backtrace (53.51 KB, text/plain)
2012-02-27 15:06 EST, Stanislav Petr
no flags Details
File: backtrace (53.84 KB, text/plain)
2012-03-30 07:05 EDT, u5afe
no flags Details

  None (edit)
Description Stanislav Petr 2012-02-27 15:05:26 EST
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/bin/python /usr/share/virt-manager/virt-manager.py
crash_function: libusb_set_debug
executable:     /usr/bin/python
kernel:         3.2.7-1.fc16.x86_64
pid:            2278
pwd:            /home/glux/Documents
reason:         Process /usr/bin/python was killed by signal 11 (SIGSEGV)
time:           Mon 27 Feb 2012 08:23:04 PM CET
uid:            1000
username:       glux

backtrace:      Text file, 54794 bytes
dso_list:       Text file, 17699 bytes
maps:           Text file, 77497 bytes

environ:
:XDG_VTNR=1
:KDE_MULTIHEAD=false
:SSH_AGENT_PID=1490
:XDG_SESSION_ID=1
:DM_CONTROL=/var/run/xdmctl
:HOSTNAME=lenovo
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:DESKTOP_STARTUP_ID=lenovo;1330370563;760126;1615_TIME125167
:TERM=dumb
:SHELL=/bin/bash
:XDG_MENU_PREFIX=kde4-
:XDM_MANAGED=method=classic
:XDG_SESSION_COOKIE=614e2906dfdae0b39db89bcc00000012-1330370494.948831-1310908205
:HISTSIZE=1000
:GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/glux/.gtkrc-2.0:/home/glux/.gtkrc-2.0-kde4:/home/glux/.kde/share/config/gtkrc-2.0
:GTK_RC_FILES=/etc/gtk/gtkrc:/home/glux/.gtkrc:/home/glux/.kde/share/config/gtkrc
:GS_LIB=
:KDE_FULL_SESSION=true
:IMSETTINGS_MODULE=none
:USER=glux
:SSH_AUTH_SOCK=/tmp/ssh-glsfZblI1329/agent.1329
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1603,unix/unix:/tmp/.ICE-unix/1603
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/local/sbin:/usr/sbin:/sbin:/home/glux/.local/bin:/home/glux/bin
:DESKTOP_SESSION=default
:MAIL=/var/spool/mail/glux
:_=/usr/libexec/kde4/start_kdeinit_wrapper
:QT_IM_MODULE=xim
:PWD=/home/glux/Documents
:XMODIFIERS=@im=none
:LANG=en_US.UTF-8
:KDE_IS_PRELINKED=1
:KDE_SESSION_UID=1000
:KDEDIRS=/usr
:HISTCONTROL=ignoredups
:SSH_ASKPASS=/usr/bin/ksshaskpass
:HOME=/home/glux
:XDG_SEAT=seat0
:SHLVL=2
:KDE_SESSION_VERSION=4
:XCURSOR_THEME=default
:LOGNAME=glux
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-ZEMo10kmDM,guid=9d3426083ac5e98daae51b0f00000038
:XDG_DATA_DIRS=/usr/share/kde-settings/kde-profile/default/share:/usr/local/share:/usr/share
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/glux
:QT_PLUGIN_PATH=/home/glux/.kde/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/:/usr/lib/kde4/plugins
:GTK_IM_MODULE=gtk-im-context-simple
:XAUTHORITY=/tmp/kde-glux/xauth-1000-_0

var_log_messages:
:Feb 27 20:19:37 lenovo kernel: [  117.371817] python[2220]: segfault at 4 ip 0000003ba8e0315b sp 00007fffa8c56078 error 4 in libusb-1.0.so.0.1.0[3ba8e00000+e000]
:Feb 27 20:19:39 lenovo abrt[2339]: Saved core dump of pid 2220 (/usr/bin/python) to /var/spool/abrt/ccpp-2012-02-27-20:19:37-2220 (72765440 bytes)
:Feb 27 20:23:04 lenovo kernel: [  145.945625] python[2278]: segfault at 4 ip 0000003ba8e0315b sp 00007fff0dad8c18 error 4 in libusb-1.0.so.0.1.0[3ba8e00000+e000]
:Feb 27 20:23:05 lenovo abrt[2360]: Saved core dump of pid 2278 (/usr/bin/python) to /var/spool/abrt/ccpp-2012-02-27-20:23:04-2278 (72716288 bytes)
Comment 1 Stanislav Petr 2012-02-27 15:05:35 EST
Created attachment 566129 [details]
File: dso_list
Comment 2 Stanislav Petr 2012-02-27 15:05:57 EST
Created attachment 566130 [details]
File: maps
Comment 3 Stanislav Petr 2012-02-27 15:06:08 EST
Created attachment 566131 [details]
File: backtrace
Comment 4 Cole Robinson 2012-02-28 16:28:11 EST
Looks like spice/usbredir. Reassigning
Comment 5 Cole Robinson 2012-03-08 08:24:23 EST
*** Bug 801098 has been marked as a duplicate of this bug. ***
Comment 6 u5afe 2012-03-30 07:05:02 EDT
Added USB redirection to virt-manager details of XP guest. After guest reboot it crashed.

backtrace_rating: 4
Package: virt-manager-0.9.1-2.fc16
OS Release: Fedora release 16 (Verne)
Comment 7 u5afe 2012-03-30 07:05:08 EDT
Created attachment 573958 [details]
File: backtrace
Comment 8 Hans de Goede 2012-03-30 08:03:43 EDT
Hi,

I believe this is a bug in spice-gtk-0.11, which is fixed by this commit:
http://cgit.freedesktop.org/spice/spice-gtk/commit/?id=434adeb05b0d8aef0d983b346bd820287db22eae
Which is in spice-gtk-0.11-3 and newer

So if you get the latest spice-gtk from updates-testing then you should no
longer see this crash. I'll update the update in bodhi to point to this bug.

Regards,

Hans
Comment 9 Fedora Update System 2012-03-30 08:04:53 EDT
libusb1-1.0.9-0.6.rc1.fc16, usbredir-0.4.2-1.fc16, spice-gtk-0.11-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-4025/usbredir-0.4.2-1.fc16,spice-gtk-0.11-4.fc16,libusb1-1.0.9-0.6.rc1.fc16
Comment 10 abrt-bot 2012-03-30 11:18:42 EDT
*** Bug 807957 has been marked as a duplicate of this bug. ***
Comment 11 Fedora Update System 2012-04-02 19:31:17 EDT
Package libusb1-1.0.9-0.6.rc1.fc16, usbredir-0.4.3-1.fc16, spice-gtk-0.11-4.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libusb1-1.0.9-0.6.rc1.fc16 usbredir-0.4.3-1.fc16 spice-gtk-0.11-4.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4025/usbredir-0.4.3-1.fc16,spice-gtk-0.11-4.fc16,libusb1-1.0.9-0.6.rc1.fc16
then log in and leave karma (feedback).
Comment 12 Frederic Grelot 2012-04-10 13:45:16 EDT
I updated everything to versions specified in #11, except spice-gtk : virt-manager still crashed (same symptoms as described above).
Then, I updated spice-gtk, and the problem was solved.
I gave karma to the update as asked in comment #11.
Comment 13 Fedora Update System 2012-04-11 12:55:52 EDT
libusb1-1.0.9-0.6.rc1.fc16, usbredir-0.4.3-1.fc16, spice-gtk-0.11-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.