Bug 798321 - v7 plan UnboundLocalError: local variable 'controllers' referenced before assignment
v7 plan UnboundLocalError: local variable 'controllers' referenced before ass...
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
6.1
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Greg Nichols
Red Hat Kernel QE team
:
Depends On:
Blocks: 767775
  Show dependency treegraph
 
Reported: 2012-02-28 11:07 EST by Petr Beňas
Modified: 2015-01-04 18:02 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no tech note needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 17:37:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0711 normal SHIPPED_LIVE v7 bug fix and enhancement update 2012-06-05 21:26:37 EDT

  None (edit)
Description Petr Beňas 2012-02-28 11:07:12 EST
Description of problem:
unable to v7 plan in v7 1.5-1

Version-Release number of selected component (if applicable):
v7-1.5-1.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. v7 plan

  
Actual results:
found interface for udisks
Traceback (most recent call last):
  File "/usr/bin/v7", line 45, in <module>
    success = v7.do(args)
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 194, in do
    result = self.commands[self.command]()
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 296, in doPlan
    tests = self.planner.plan() 
  File "/usr/share/v7/lib/v7/planner.py", line 115, in plan
    self.plannedTests = self.__plan(self.devices)
  File "/usr/share/v7/lib/v7/planner.py", line 99, in __plan
    someTests = test.plan(self.devices)
  File "/usr/share/v7/tests/storage/storage.py", line 53, in plan
    disk = self.planHAL(device, devices)
  File "/usr/share/v7/tests/storage/storage.py", line 91, in planHAL
    if controllerId in controllers:
UnboundLocalError: local variable 'controllers' referenced before assignment


Expected results:
Please verify the vendor, make, and model:
Vendor: Hewlett-Packard
Make: HP
Model: HP xw6400 Workstation
Hardware: Hewlett-Packard HP HP xw6400 Workstation
OS: Santiago 6.2
saved configuration to /var/v7/results.xml
Created a new plan with 22 tests on 131 devices
Checking for additional required packages based on the test plan:
... and so on

Additional info:
Possibly regression, works in v7-1.4-38.el6.noarch.
Comment 2 Greg Nichols 2012-03-02 08:54:31 EST
Fix committed to v7 1.5 R2.
Comment 7 Petr Beňas 2012-03-29 04:49:50 EDT
Verified in R3.
Comment 8 Caspar Zhang 2012-06-04 03:53:11 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
no tech note needed.
Comment 10 errata-xmlrpc 2012-06-05 17:37:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0711.html

Note You need to log in before you can comment on or make changes to this bug.