Bug 798324 - When creating permissions some Verbs have tags when they should not
When creating permissions some Verbs have tags when they should not
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
medium Severity medium (vote)
: Unspecified
: --
Assigned To: Eric Helms
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-28 11:09 EST by Eric Helms
Modified: 2014-09-18 11:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-22 14:29:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Helms 2012-02-28 11:09:22 EST
Description of problem:
When creating permissions some verbs display tags as a selectable option when in fact those verbs apply to all resources of that type.

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. Open Roles Page
2. Navigate into organization 'ACME_Corporation'
3. Click Add Permission
4. Select Providers
5. Click 'Next'
6. Choose 'Administer Providers'
7. Click 'Next'
  
Actual results:
Tags selection box appears allowing you to select one or more resources.

Expected results:
No tags selection box should appear as the verb applies to all resources of that type by default.

Additional info:
Comment 2 Mike McCune 2012-03-07 18:44:31 EST
mass move ON_QA after brewing
Comment 3 Jeff Weiss 2012-03-08 14:19:03 EST
Verified, Katello Version: 0.2.8-1.git.11.033f96d.el6
Comment 5 Mike McCune 2013-08-16 14:22:09 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.