Bug 798400 - Alt-SysRq Sync -> Readonly -> Boot causes partially old files on system
Alt-SysRq Sync -> Readonly -> Boot causes partially old files on system
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-28 14:23 EST by Peter Bieringer
Modified: 2012-03-01 04:24 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-01 04:24:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2012-02-28 14:23:30 EST
Description of problem:
During problems with the Intel Software RAID (https://bugzilla.redhat.com/show_bug.cgi?id=752593) it turned out, that

Alt-SysRq Sync (S) -> Readonly (U) -> Boot (B) results, that old files on the system.

Version-Release number of selected component (if applicable):
3.2.7-1.fc16.i686.PAE


How reproducible:
Sometimes

Steps to Reproduce:
1. Update e.g. dracut
2. reboot (hangs because of Intel Software RAID problems)
3. Alt-SysRq S,U,B
  
Actual results:
System immediatelly boots (without any store of raid sync status and so on)
System booted,

"rpm -V dracut" reports checksum mismatch

Expected results:
Either Alt-SysRq S working proper (which looks like did not) or Alt-SysRq B try to sync anything outstanding like e.g. Alt-SysRq O (poweroff) does.

Additional info:
Filesystem is ext4
Comment 1 Josh Boyer 2012-02-28 14:32:56 EST
Jes, I know there are fixes queued for Intel Software RAID somewhere.  Eric, the fs in question is ext4.  You guys can duke it out...

FIGHT!
Comment 2 Jes Sorensen 2012-02-29 03:13:58 EST
Peter,

Does this also happen after you updated to dracut-017 as you reported in
BZ#752593?

The problem with IMSM RAID is that if we get into the reboot hang stage,
mdmon will not finish writing out the metadata to the RAID and you can
end up with files not making it out to disk. If you can reproduce this
with dracut-017 installed, then it is likely another problem.

Thanks,
Jes
Comment 3 Peter Bieringer 2012-02-29 13:18:10 EST
(In reply to comment #2)
> Peter,
> 
> Does this also happen after you updated to dracut-017 as you reported in
> BZ#752593?

No longer, it looks like that something was extended now,

Alt-SysRq U for "readonly" now reports

EXT4-fs (md127p1): remounted. Ops:(null)
EXT4-fs (md127p8): remounted. Ops:(null)

Alt-SysRq O for "off" displays now similar messages regarding RAID as on reboot.

So the new dracut version fixes this issue - also after power-on BIOS *and* Windows reports the IMSM RAID as clean (which was not always the case in the past)
Comment 4 Jes Sorensen 2012-03-01 04:24:26 EST
Peter,

This is good news! Sounds like the problem was caused by mdmon not managing
to write out the metadata then.

I'll close this bug, but if you see this problem again, please go ahead
and reopen it.

Cheers,
Jes

Note You need to log in before you can comment on or make changes to this bug.