Bug 798411 - fails to build on s390x
fails to build on s390x
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openssl (Show other bugs)
rawhide
s390x Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-28 14:47 EST by Dan Horák
Modified: 2012-03-01 03:10 EST (History)
1 user (show)

See Also:
Fixed In Version: openssl-1.0.1-0.2.beta3.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-29 16:22:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2012-02-28 14:47:36 EST
Description of problem:

openssl fails to build on F-17/s390x with:
...
make[2]: Entering directory `/builddir/build/BUILD/openssl-1.0.1-beta2'
[ -z "" ] || gcc -fPIC -DOPENSSL_PIC -DZLIB -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -DKRB5_MIT -m64 -DB_ENDIAN -DTERMIO -Wall -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m64 -march=z9-109 -mtune=z10 -Wa,--noexecstack -DOPENSSL_BN_ASM_MONT -DOPENSSL_BN_ASM_GF2m -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM -DAES_ASM -DAES_CTR_ASM -DAES_XTS_ASM -DGHASH_ASM -Iinclude \
        -DFINGERPRINT_PREMAIN_DSO_LOAD -o fips_premain_dso  \
        fips_premain.c fipscanister.o \
        libcrypto.a -ldl -lz
make[3]: Entering directory `/builddir/build/BUILD/openssl-1.0.1-beta2'
make[4]: Entering directory `/builddir/build/BUILD/openssl-1.0.1-beta2'
libcrypto.a(rc4_utl.o): In function `RC4_set_key':
/builddir/build/BUILD/openssl-1.0.1-beta2/crypto/rc4/rc4_utl.c:57: multiple definition of `RC4_set_key'
libcrypto.a(rc4-s390x.o):/builddir/build/BUILD/openssl-1.0.1-beta2/crypto/rc4/rc4-s390x.s:193: first defined here
collect2: error: ld returned 1 exit status
make[4]: *** [link_a.gnu] Error 1
make[4]: Leaving directory `/builddir/build/BUILD/openssl-1.0.1-beta2'



Version-Release number of selected component (if applicable):
openssl-1.0.1-0.1.beta2.fc17

Also the configuration name seems to be changed from linux-s390x to linux64-s390x (http://s390.koji.fedoraproject.org/koji/getfile?taskID=604755&name=build.log)
Comment 1 Tomas Mraz 2012-02-29 16:22:03 EST
Should be fixed on rawhide. Please try it.
Comment 2 Dan Horák 2012-03-01 03:10:58 EST
Thanks, built successfully on both s390 and s390x using f17 buildroot.

Note You need to log in before you can comment on or make changes to this bug.