Bug 798489 - Get "undefined method" while displaying user information without domain created
Get "undefined method" while displaying user information without domain created
Status: CLOSED DUPLICATE of bug 798643
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Krishna Raman
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-28 21:35 EST by jizhao
Modified: 2015-05-14 21:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-29 15:01:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jizhao 2012-02-28 21:35:53 EST
Description of problem:
Get error when run "rhc domain show" or "rhc-domain-info" without domain created.

Version-Release number of selected component (if applicable):
rhc-node-0.87.7-1.el6_2.x86_64
rhc-broker-0.87.9-1.el6_2.noarch
rhc-0.87.6-1.el6_2.noarch

How reproducible:
Always

Steps to Reproduce:
1.Destroy domain if the user has created domain
2.View the user information
$ rhc domain show -d
or
$ rhc-domain-info -aid
3.
  
Actual results:
<-----------output----------->
Contacting https://ec2-107-21-183-45.compute-1.amazonaws.com
Problem reported from server. Response code was 500.

DEBUG:
undefined method `auth_method=' for nil:NilClass/usr/lib/ruby/gems/1.8/gems/activesupport-3.0.10/lib/active_support/whiny_nil.rb:48:in `method_missing'
/usr/lib/ruby/gems/1.8/gems/cloud-sdk-controller-0.5.9/lib/cloud-sdk-controller/app/controllers/legacy_broker_controller.rb:10:in `user_info_post'
/usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_controller/metal/implicit_render.rb:4:in `send_action'
/usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_controller/metal/implicit_render.rb:4:in `send_action'
/usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/abstract_controller/base.rb:150:in `process_action'
/usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_controller/metal/rendering.rb:11:in `process_action'

Exit Code: 1
broker_c: namespacerhloginsshapp_uuiddebugaltercartridgecart_typeactionapp_nameapi
api_c: placeholder
API version:    1.1.2

RESULT:
undefined method `auth_method=' for nil:NilClass
<---------------------------->

Expected results:
There shouldn't be any error. The output should say the user doesn't have any created domain.

Additional info:
Comment 1 Abhishek Gupta 2012-02-29 15:01:01 EST

*** This bug has been marked as a duplicate of bug 798643 ***

Note You need to log in before you can comment on or make changes to this bug.