Bug 798505 - Replace Deployable text with application Blueprint.
Replace Deployable text with application Blueprint.
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity low
: beta4
: ---
Assigned To: Jason Guiditta
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 00:26 EST by Aziza Karol
Modified: 2012-05-15 18:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 18:47:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ref (217.71 KB, image/png)
2012-02-29 00:27 EST, Aziza Karol
no flags Details
ref1 (197.53 KB, image/png)
2012-03-07 01:42 EST, Aziza Karol
no flags Details

  None (edit)
Description Aziza Karol 2012-02-29 00:26:48 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
On the deployable page click on Grant access.
see attached screenshot.
  



Expected results:
Replace Deployable text with application Blueprint.

Additional info:
rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-10.el6.noarch
aeolus-conductor-daemons-0.8.0-38.el6.noarch
aeolus-all-0.8.0-38.el6.noarch
rubygem-aeolus-cli-0.3.0-11.el6.noarch
aeolus-conductor-doc-0.8.0-38.el6.noarch
aeolus-configure-2.5.0-15.el6.noarch
aeolus-conductor-0.8.0-38.el6.noarch
Comment 1 Aziza Karol 2012-02-29 00:27:26 EST
Created attachment 566457 [details]
ref
Comment 2 Scott Seago 2012-03-02 11:35:10 EST
This seems to be a duplicate of Bug 798501 -- it's the same issue. The reusable permissions panel references the model object type for display -- which would include Deployable, PoolFamily, etc. The fix is the same as for 798501 -- we need i18n strings for the classnames.
Comment 3 Jason Guiditta 2012-03-02 16:33:31 EST
Agree this is the same bug, posting ref to patch here too:

Sent to list - 

commit 90393e54cf96df58a2b4c2960abef14bcaa9c743
Author: Jason Guiditta <jguiditt@redhat.com>
Date:   Fri Mar 2 16:21:54 2012 -0500

    BZs #798501 and #798505: Object names should be pulled from mapping file
    
    https://bugzilla.redhat.com/show_bug.cgi?id=798505
    https://bugzilla.redhat.com/show_bug.cgi?id=798501
    
    This boils down to the following: The strings in question were NOT
    being internationalized, they were pulled from the class names.  This
    patch adds a mapping i18n file, which fixes both bugs (and any similar)
    and future ones saying we don't internationalize the class names.
    
    It is possible there are other cases beside permissions where this
    maybe be the case, but if so, it is a simple matter of repeating the
    pattern here and add a few translation strings to this file.
Comment 4 Jason Guiditta 2012-03-05 18:09:09 EST
This has been pushed to master
Comment 6 Aziza Karol 2012-03-07 01:36:43 EST
Reference to deployable removed.

see attached screenshot.

verified:
rpm  -qa | grep aeolus
aeolus-conductor-doc-0.8.0-41.el6.noarch
aeolus-conductor-daemons-0.8.0-41.el6.noarch
rubygem-aeolus-cli-0.3.0-13.el6.noarch
aeolus-all-0.8.0-41.el6.noarch
aeolus-conductor-0.8.0-41.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-configure-2.5.0-18.el6.noarch
Comment 7 Aziza Karol 2012-03-07 01:42:43 EST
Created attachment 568158 [details]
ref1
Comment 9 errata-xmlrpc 2012-05-15 18:47:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0583.html

Note You need to log in before you can comment on or make changes to this bug.