Bug 798510 - No message displayed if the user tries to Build an image in a new cloud without adding a provider account to it.
No message displayed if the user tries to Build an image in a new cloud witho...
Status: CLOSED DUPLICATE of bug 806846
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: 1.0.2
: ---
Assigned To: Jiri Tomasek
wes hayutin
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 00:49 EST by Aziza Karol
Modified: 2012-10-29 10:55 EDT (History)
8 users (show)

See Also:
Fixed In Version: v0.13.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-29 10:55:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build (236.78 KB, image/png)
2012-02-29 00:50 EST, Aziza Karol
no flags Details
err msg (211.52 KB, image/png)
2012-06-22 01:56 EDT, Aziza Karol
no flags Details

  None (edit)
Description Aziza Karol 2012-02-29 00:49:46 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.created a new cloud "cloud-aziza".created a new zone "aziza" in "cloud-aziza".
2.in the cloud "cloud-aziza",click on new component outline and build an image using upload url.save the component outline and it will take you to provider images page.
3.click on build button.
  

Actual results:
No message is displayed. see attached  screenshot.

Expected results:
A message stating "please add provider account to that cloud" should be displayed if the user tries to build without adding an account in the new cloud created.

Additional info:
rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-10.el6.noarch
aeolus-conductor-daemons-0.8.0-38.el6.noarch
aeolus-all-0.8.0-38.el6.noarch
rubygem-aeolus-cli-0.3.0-11.el6.noarch
aeolus-conductor-doc-0.8.0-38.el6.noarch
aeolus-configure-2.5.0-15.el6.noarch
aeolus-conductor-0.8.0-38.el6.noarch
Comment 1 Aziza Karol 2012-02-29 00:50:35 EST
Created attachment 566466 [details]
build
Comment 2 Jiri Tomasek 2012-03-19 05:25:00 EDT
fix posted in https://fedorahosted.org/pipermail/aeolus-devel/2012-March/009603.html
Comment 3 Jiri Tomasek 2012-03-19 11:13:22 EDT
fixed in commit d8c3203f24514d61fd0c082891965c149fc60ac3
Comment 5 Aziza Karol 2012-06-22 01:55:30 EDT
Error message "Images cannot be built, as no provider accounts are currently enabled" displayed if the user tries to Build an image in a new cloud without adding a provider account. see attached screenshot.

verified:
rpm -qa | grep aeolus
aeolus-conductor-daemons-0.8.30-1.el6_2.noarch
aeolus-configure-2.5.7-2.el6_2.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.8.30-1.el6_2.noarch
rubygem-aeolus-cli-0.3.3-2.el6_2.noarch
aeolus-conductor-doc-0.8.30-1.el6_2.noarch
aeolus-all-0.8.30-1.el6_2.noarch
Comment 6 Aziza Karol 2012-06-22 01:56:43 EDT
Created attachment 593647 [details]
err msg
Comment 7 Steve Linabery 2012-10-29 10:55:28 EDT

*** This bug has been marked as a duplicate of bug 806846 ***

Note You need to log in before you can comment on or make changes to this bug.