Bug 798541 - device-mapper-multipath: standard rpm cflags not used during build [rhel-6]
device-mapper-multipath: standard rpm cflags not used during build [rhel-6]
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ben Marzinski
Gris Ge
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 03:24 EST by Tomas Hoger
Modified: 2012-06-20 10:37 EDT (History)
10 users (show)

See Also:
Fixed In Version: device-mapper-multipath-0.4.9-49.el6
Doc Type: Bug Fix
Doc Text:
No Documentation needed
Story Points: ---
Clone Of:
: 798543 (view as bug list)
Environment:
Last Closed: 2012-06-20 10:37:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Hoger 2012-02-29 03:24:46 EST
Description of problem:
spec file for device-mapper-multipath does not use rpm macro %configure and invokes make without explicitly adding default rpm cflags.  As a consequence, build is not made with optimization level and protections expected to be the default for all packages.

Version-Release number of selected component (if applicable):
device-mapper-multipath-0.4.9-46.el6
Comment 2 Ben Marzinski 2012-03-03 21:50:42 EST
How do I explicitly add the default rpm cflags? the device-mapper-multipath package doesn't use autoconf or automake so there's not much point in using
%configure

Is it possible to run the %configure macro without actually needing it to do
any of the autotools work?
Comment 4 Ben Marzinski 2012-03-04 14:06:44 EST
It looks like all I need to do is pass "$RPM_OPT_FLAGS" to make from the spec file.

Something like

%build
make RPM_OPT_FLAGS="$RPM_OPT_FLAGS"

and then make sure that the Makefiles include those with the other CFLAGS.  Or is there something else that needs to be done?
Comment 5 Tomas Hoger 2012-03-05 04:35:31 EST
(In reply to comment #4)
> %build
> make RPM_OPT_FLAGS="$RPM_OPT_FLAGS"

Right, passing in RPM_OPT_FLAGS and adding them to CFLAGS in Makefile.inc should to the trick.
Comment 6 Ben Marzinski 2012-03-14 15:54:02 EDT
device-mapper-multipath.spec now passes in RPM_OPT_FLAGS, and the Makefiles use it.  It did flush out a couple of issues, and I've cleaned up the code so that it doesn't issue warnings about some more things.
Comment 8 Ben Marzinski 2012-04-28 00:57:12 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No Documentation needed
Comment 9 Gris Ge 2012-05-22 00:00:45 EDT
No issue found in errata TPS test (include compile test).

No regression found in device-mapper-multipath-0.4.9-56.el6.x86_64.

VERIFY.
Comment 11 errata-xmlrpc 2012-06-20 10:37:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0946.html

Note You need to log in before you can comment on or make changes to this bug.