Bug 798567 - French : Provider quota is set to zero by default
French : Provider quota is set to zero by default
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity high
: beta4
: ---
Assigned To: Shveta
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 04:30 EST by Shveta
Modified: 2012-05-15 18:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 18:48:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
zero_provider_quota (218.55 KB, image/png)
2012-02-29 04:30 EST, Shveta
no flags Details
able to create account (234.83 KB, image/png)
2012-03-06 23:20 EST, Shveta
no flags Details

  None (edit)
Description Shveta 2012-02-29 04:30:23 EST
Created attachment 566498 [details]
zero_provider_quota

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Enabled french , Create provider account 
2. Provider quota is set to 0 by default as against (unlimited) in english version
3. Also the "Unlimited" button is not aligned 
  
Actual results:


Expected results:


Additional info:

rpm -qa|grep aeolus
aeolus-conductor-0.8.0-38.el6.noarch
aeolus-all-0.8.0-38.el6.noarch
aeolus-conductor-daemons-0.8.0-38.el6.noarch
aeolus-configure-2.5.0-15.el6.noarch
rubygem-aeolus-image-0.3.0-10.el6.noarch
rubygem-aeolus-cli-0.3.0-11.el6.noarch
aeolus-conductor-doc-0.8.0-38.el6.noarch
Comment 1 Shveta 2012-02-29 04:32:00 EST
Even after clicking the "unlimited" button the account could not be saved.
It gives message :Quota maximum running instances must be a positive whole number less than 2147483647
and sets the quota to zero again.
Comment 2 Angus Thomas 2012-03-02 08:28:15 EST
There's logic here which deals with "unlimited" as the string, but isn't working with "illimité(e)"

The code needs to be fixed up so that the quota is set to unlimited when the Unlimited button is pressed. irrespective of the string that appears in the text entry field.
Comment 3 Scott Seago 2012-03-02 09:53:46 EST
Yeah, the original design here was 'empty quota == unlimited' -- adding the 'unlimited' string there has caused a bit of confusion now. However, the fix is probably as simple as ignoring non-numeric data in the string so 'unlimited' == '' == 'halibut express'
Comment 4 Tzu-Mainn Chen 2012-03-02 10:35:16 EST
Patch created:

https://fedorahosted.org/pipermail/aeolus-devel/2012-March/009358.html
Comment 5 Tzu-Mainn Chen 2012-03-06 11:45:08 EST
Patch pushed to master:

commit a35f30d6cc3c26b12e242f85a36086fad6ec2b3a
BZ 798567 use Il8n version of unlimited

commit 12107d15c160c6506f63e630307b5f6380c1abe8
BZ 798567 fix to allow Il8n'd version of 'unlimited' to count as unlimited
Comment 7 Shveta 2012-03-06 23:20:27 EST
Created attachment 568123 [details]
able to create account

Quota is set to unlimited by default, able to create account now

 rpm -qa|grep aeolus
aeolus-conductor-doc-0.8.0-41.el6.noarch
aeolus-conductor-daemons-0.8.0-41.el6.noarch
rubygem-aeolus-cli-0.3.0-13.el6.noarch
aeolus-all-0.8.0-41.el6.noarch
aeolus-conductor-0.8.0-41.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-configure-2.5.0-18.el6.noarch
Comment 8 errata-xmlrpc 2012-05-15 18:48:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0583.html

Note You need to log in before you can comment on or make changes to this bug.