Bug 798680 - No items in Operations tab in SOA-P 4 server
No items in Operations tab in SOA-P 4 server
Status: CLOSED NOTABUG
Product: JBoss Enterprise SOA Platform 4
Classification: JBoss
Component: JON (Show other bugs)
4.3 CP05
i386 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: tcunning
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 10:02 EST by Pavel Kralik
Modified: 2013-04-30 19:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-14 09:49:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Kralik 2012-02-29 10:02:36 EST
Description of problem:
There are no items (Start, Stop, Reset) in Operations tab in all hierarchy of
the SOA-P 4 Server

Version-Release number of selected component (if applicable):
Fedora 13
jon-server-3.0.1.GA-5
soa-4.3.0.GA_CP05
PostgreSQL 8.4.8
FF 3.6.17

How reproducible:
Always

Steps to Reproduce:
1. Instal SOA-P 5.2.GA
2. Start JON Server 3.0.1
3. Inventory the SOA-P server into the JON, update connection properties and go
anywhere in the SOA-P hierarchy (SOA server, JBoss ESB, etc.) into Operations
tab and see the exception.

Actual results:
org.rhq.core.pluginapi.inventory.InvalidPluginConfigurationException: Failed to start component for resource Resource[id=10004, type=JBossAS Server, key=/home/pkralik/jon_test/soa/jboss-soa-p.4.3.0/jboss-as/server/production, name=SOA kapr.brq.redhat.com:1099 production, parent=kapr.brq.redhat.com, version=SOA 4.3.0.GA_CP05_SOA].
	at org.rhq.core.pc.inventory.InventoryManager.activateResource(InventoryManager.java:1625)
	at org.rhq.core.pc.inventory.AvailabilityExecutor.checkInventory(AvailabilityExecutor.java:202)
	at org.rhq.core.pc.inventory.AvailabilityExecutor.checkInventory(AvailabilityExecutor.java:238)
	at org.rhq.core.pc.inventory.AvailabilityExecutor.call(AvailabilityExecutor.java:127)
	at org.rhq.core.pc.inventory.AvailabilityExecutor.call(AvailabilityExecutor.java:55)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:165)
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:636)
Caused by: org.rhq.core.pluginapi.inventory.InvalidPluginConfigurationException: Invalid JMX credentials specified for connecting to this server.
	at org.rhq.plugins.jbossas.JBossASServerComponent.start(JBossASServerComponent.java:255)
	at sun.reflect.GeneratedMethodAccessor47.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread.call(ResourceContainer.java:552)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
	... 3 more
Caused by: org.mc4j.ems.connection.EmsConnectException: Connection failure Failed to authenticate principal=null, securityDomain=jmx-console
	at org.mc4j.ems.impl.jmx.connection.support.providers.proxy.GenericMBeanServerProxy.invoke(GenericMBeanServerProxy.java:139)
	at $Proxy54.queryNames(Unknown Source)
	at org.mc4j.ems.impl.jmx.connection.DConnection.loadSynchronous(DConnection.java:133)
	at org.rhq.plugins.jbossas.JBossASServerComponent.loadConnection(JBossASServerComponent.java:1120)
	at org.rhq.plugins.jbossas.JBossASServerComponent.start(JBossASServerComponent.java:247)
	... 9 more
Caused by: java.lang.SecurityException: Failed to authenticate principal=null, securityDomain=jmx-console
	at org.jboss.jmx.connector.invoker.AuthenticationInterceptor.invoke(AuthenticationInterceptor.java:97)
	at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
	at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
	at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
	at org.jboss.invocation.jrmp.server.JRMPProxyFactory.invoke(JRMPProxyFactory.java:180)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:155)
	at org.jboss.mx.server.Invocation.dispatch(Invocation.java:94)
	at org.jboss.mx.server.Invocation.invoke(Invocation.java:86)
	at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
	at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
	at org.jboss.invocation.jrmp.server.JRMPInvoker$MBeanServerAction.invoke(JRMPInvoker.java:818)
	at org.jboss.invocation.jrmp.server.JRMPInvoker.invoke(JRMPInvoker.java:419)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:322)
	at sun.rmi.transport.Transport$1.run(Transport.java:177)
	at java.security.AccessController.doPrivileged(Native Method)
	at sun.rmi.transport.Transport.serviceCall(Transport.java:173)
	at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:553)
	at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(TCPTransport.java:808)
	at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:667)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:636)
	at sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer(StreamRemoteCall.java:273)
	at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:251)
	at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:160)
	at org.jboss.invocation.jrmp.server.JRMPInvoker_Stub.invoke(Unknown Source)
	at org.jboss.invocation.jrmp.interfaces.JRMPInvokerProxy.invoke(JRMPInvokerProxy.java:133)
	at org.jboss.invocation.InvokerInterceptor.invokeInvoker(InvokerInterceptor.java:365)
	at org.jboss.invocation.InvokerInterceptor.invoke(InvokerInterceptor.java:197)
	at org.jboss.jmx.connector.invoker.client.InvokerAdaptorClientInterceptor.invoke(InvokerAdaptorClientInterceptor.java:66)
	at org.jboss.proxy.SecurityInterceptor.invoke(SecurityInterceptor.java:70)
	at org.jboss.proxy.ClientMethodInterceptor.invoke(ClientMethodInterceptor.java:74)
	at org.jboss.proxy.ClientContainer.invoke(ClientContainer.java:100)
	at $Proxy53.queryNames(Unknown Source)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.mc4j.ems.impl.jmx.connection.support.providers.proxy.GenericMBeanServerProxy.invokeInternal(GenericMBeanServerProxy.java:168)
	at org.mc4j.ems.impl.jmx.connection.support.providers.proxy.GenericMBeanServerProxy.invoke(GenericMBeanServerProxy.java:103)
	... 13 more

Expected results:
Operations links.

Additional info:
Comment 1 Len DiMaggio 2012-03-02 11:13:08 EST
Marking this as urgent as this is a regression.
Comment 2 Pavel Kralik 2012-03-07 12:18:06 EST
The exception is in upper right corner as a white triangle next to availability icon in the the SOA-P server resource.
Comment 3 tcunning 2012-03-07 13:14:32 EST
See comment: https://bugzilla.redhat.com/show_bug.cgi?id=798677#c3

I have not tested this with SOA-P 4 (tried with SOA-P5 , but the trace sees to suggest it is related to the problem observed there.
Comment 4 Len DiMaggio 2012-03-14 09:34:45 EDT
Usability issue - will be covered in the docs - from Deon:


I updated three places in the docs, just to try to hit places people might look if they encountered that Operations tab question. This is all basically the same text.

    * FAQ: http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Operations_Network/300/html/Frequently_Asked_Questions/index.html#id3333992
    * "About" operations: http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Operations_Network/3.0/html/Setting_up_Monitoring_Alerts_and_Operations/Operations.html#op-scheds (looks like this is missing an image; I'll check and get that fixed)
    * Scheduling operations (procedure): http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Operations_Network/3.0/html/Setting_up_Monitoring_Alerts_and_Operations/OperationProc.html#Creating-New-Operations

Note You need to log in before you can comment on or make changes to this bug.