Bug 798769 - Redrawing bug when alt+tab using RHEL6 guest, spice, vmvga
Redrawing bug when alt+tab using RHEL6 guest, spice, vmvga
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 15:00 EST by Cosimo Cecchi
Modified: 2013-05-27 11:57 EDT (History)
22 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-27 11:57:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
video of the bug (1.60 MB, video/webm)
2012-02-29 15:00 EST, Cosimo Cecchi
no flags Details

  None (edit)
Description Cosimo Cecchi 2012-02-29 15:00:02 EST
Created attachment 566628 [details]
video of the bug

Description of problem:

See attached video; basically some times switching to a window with Alt+Tab doesn't trigger a repaint of the window area. The effect is very weird, since moving the mouse cursor will trigger a repaint of the area around it (as expected), making the content of that window gradually appear underneath it.
In the video I'm switching between a gnome-terminal window and an emacs one.

This virtual machine is using the vmvga video driver. It's a RHEL 6.2 workstation install running in a F17 virt-manager.
Comment 2 Dave Allan 2012-02-29 16:52:57 EST
I think this is more likely to be a virt-manager bug than a libvirt one since libvirt sets up the VM configuration but doesn't handle the screen display.  I'm moving the BZ to virt-manager.  Cole, let me know what you think.
Comment 3 Cole Robinson 2012-02-29 21:04:47 EST
Cosimo, is the guest using SPICE or VNC? Does changing that make any difference? 

Does switching the guest video hardware to something else change this behavior (since you specifically mentioned vmvga)?
Comment 4 Cosimo Cecchi 2012-03-01 10:48:40 EST
(In reply to comment #3)
> Cosimo, is the guest using SPICE or VNC? Does changing that make any
> difference? 
> 
> Does switching the guest video hardware to something else change this behavior
> (since you specifically mentioned vmvga)?


It's using SPICE. Unfortunately the bug is not always reproducible (and I am not able to reproduce it now) so I can't really tell now whether changing these options would make a difference. I thought it was worth mentioning the guest video driver because I have sometimes seen different rendering bugs by changing the driver in the past.
Comment 5 Cole Robinson 2012-03-01 10:54:15 EST
Okay, this is probably a qemu or guest bug. Moving to qemu for now
Comment 8 Ademar Reis 2012-06-29 11:11:20 EDT
Cosimo, I'm moving this bug to Fedora, since only the guest is using RHEL. If you manage to reproduce it using RHEL, please move it back to us.
Comment 10 Cole Robinson 2013-05-25 15:34:29 EDT
Since this bug has lingered for a while, and the original reporter is gone, just closing this. If anyone can still reproduce it's better off to just move it upstream since it likely won't get much traction in the Fedora tracker.

Note You need to log in before you can comment on or make changes to this bug.