This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 798831 - Process inserts duplicate previous and next steps
Process inserts duplicate previous and next steps
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 21:40 EST by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 21:31:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-02-29 21:40:05 EST
e.g: from the build of SPEC ID: 6192


4.3.3. Create your first Content Spec
Previous Steps in Basic Content Spec Tutorial
Section 4.3.2, “Configure csprocessor for the test server”
Section 4.3.2, “Configure csprocessor for the test server”




Result:

You now have a Content Spec for a test book with one chapter and one topic.
Next Steps in Basic Content Spec Tutorial
Section 4.3.4, “Push your first Content Spec to the server”
Section 4.3.4, “Push your first Content Spec to the server”
Comment 1 Joshua Wulf 2012-02-29 21:45:43 EST
Spec revision: 42109

Web Service at http://csprocessor.cloud.lab.eng.bne.redhat.com:8080/ version: 0.21.4
Comment 2 Lee Newson 2012-03-05 01:37:40 EST
Fixed in 0.22.0.

Cause:
The problem was due to a memory issue because Java stores references for Objects, I was trying to modify one object and it was modifying the same object. I was then adding the relationships twice without intentionally doing so.

Consequence:
Two relationships were being created.

Fix:
The relationships that are added are now done so that a new object that doesn't reference the old in created. This stops the duplicate relationship issue.
Comment 3 Lee Newson 2013-06-06 21:31:25 EDT
Closing and setting as current release as no QA was performed by the original reporter. If there is still an issue with this bug still than please re-open it.

Note You need to log in before you can comment on or make changes to this bug.