Bug 798847 - Table contents overrun cells in PDFs
Table contents overrun cells in PDFs
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.0
All All
unspecified Severity medium
: 3.0
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 23:30 EST by Kate Grainger
Modified: 2012-10-30 23:11 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 23:11:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Table overrun 1 (56.22 KB, image/png)
2012-02-29 23:30 EST, Kate Grainger
no flags Details
Table overrun 2 (17.84 KB, image/png)
2012-02-29 23:31 EST, Kate Grainger
no flags Details

  None (edit)
Description Kate Grainger 2012-02-29 23:30:43 EST
Created attachment 566735 [details]
Table overrun 1

Description of problem:
For 3-column tables that contain very long cell values, these values can overrun the cell width. This behaviour only happens in PDFs.

How reproducible:
The limit seems to be around 25-30 characters wide.

Steps to Reproduce:
1. Create a 3-column table with very long cell values.
2. Generate a PDF.
3. Observe over-runnage.
4. Weep, gnash teeth.
  
Actual results:
Cell contents overrun cell delimiters.

Expected results:
Cell contents are fully contained within cell delimiters.

Additional info:
See screen shots for examples.
Comment 1 Kate Grainger 2012-02-29 23:31:32 EST
Created attachment 566736 [details]
Table overrun 2
Comment 2 Ruediger Landmann 2012-06-18 01:12:19 EDT
Verified on publican-3.0-0.fc17.t180.noarch

wkhtmltopdf is much better at laying out tables than FOP was.

Note You need to log in before you can comment on or make changes to this bug.