Bug 798849 - max_image_width: 660 ignored for PDF builds
max_image_width: 660 ignored for PDF builds
Status: CLOSED WONTFIX
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.0
All All
unspecified Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 23:57 EST by Kate Grainger
Modified: 2012-03-11 19:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-11 19:47:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Page overrun 1 (135.81 KB, image/png)
2012-02-29 23:57 EST, Kate Grainger
no flags Details
Page overrun 2 (75.15 KB, image/png)
2012-02-29 23:59 EST, Kate Grainger
no flags Details

  None (edit)
Description Kate Grainger 2012-02-29 23:57:48 EST
Created attachment 566743 [details]
Page overrun 1

Description of problem:
Very large (wide) images are not being scaled to fit within the page width of PDFs, even when max_image_width: 660 is set in publican.cfg.

How reproducible:
Twenty figures in the RHEV suite of books have overrun in the PDF format.

Steps to Reproduce:
1. Create a very large (wide) image and include it in your xml.
2. Generate a PDF.
3. Your page runneth over.
4. Weep, gnash teeth.

Actual results:
Figures overrun page width.

Expected results:
Figures are constrained to the max_image_width of 660px.

Additional info:
See screen shots for examples.
Comment 1 Kate Grainger 2012-02-29 23:59:12 EST
Created attachment 566744 [details]
Page overrun 2
Comment 2 Jeff Fearn 2012-03-11 19:47:55 EDT
Image sizes above 440px are not supported when using FOP because you have to use external tools to change the image DPI or it doesn't work properly. We do not have the person power to support this kind of thing and people choosing to use it must support themselves.

Note You need to log in before you can comment on or make changes to this bug.