Bug 798921 - SELinux is preventing /usr/sbin/php-fpm from 'name_bind' accesses on the None .
SELinux is preventing /usr/sbin/php-fpm from 'name_bind' accesses on the None .
Status: CLOSED DUPLICATE of bug 798924
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:6abb14ce02d6d75ea57c4e07e7a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 04:40 EST by Renich Bon Ciric
Modified: 2012-03-01 06:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-01 06:54:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Renich Bon Ciric 2012-03-01 04:40:46 EST
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.2.7-1.fc16.x86_64
reason:         SELinux is preventing /usr/sbin/php-fpm from 'name_bind' accesses on the None .
time:           Thu 01 Mar 2012 03:40:34 AM CST

description:
:SELinux is preventing /usr/sbin/php-fpm from 'name_bind' accesses on the None .
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that php-fpm should be allowed name_bind access on the  <Unknown> by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep php-fpm /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:httpd_t:s0
:Target Context                system_u:object_r:unreserved_port_t:s0
:Target Objects                 [ None ]
:Source                        php-fpm
:Source Path                   /usr/sbin/php-fpm
:Port                          9000
:Host                          (removed)
:Source RPM Packages           php-fpm-5.3.10-1.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-78.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.2.7-1.fc16.x86_64 #1 SMP
:                              Tue Feb 21 01:40:47 UTC 2012 x86_64 x86_64
:Alert Count                   10
:First Seen                    Thu 01 Mar 2012 03:40:09 AM CST
:Last Seen                     Thu 01 Mar 2012 03:40:18 AM CST
:Local ID                      0d161235-625d-42fb-a869-f17afe98617b
:
:Raw Audit Messages
:type=AVC msg=audit(1330594818.249:284): avc:  denied  { name_bind } for  pid=21914 comm="php-fpm" src=9000 scontext=system_u:system_r:httpd_t:s0 tcontext=system_u:object_r:unreserved_port_t:s0 tclass=tcp_socketnode=(removed) type=SYSCALL msg=audit(1330594818.249:284): arch=c000003e syscall=49 success=no exit=-13 a0=6 a1=7ffff7c110b0 a2=10 a3=7ffff7c10ffc items=0 ppid=21911 pid=21914 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="php-fpm" exe="/usr/sbin/php-fpm" subj=system_u:system_r:httpd_t:s0 key=(null)
:
:
:Hash: php-fpm,httpd_t,unreserved_port_t,None,name_bind
:
:audit2allow
:
:
:audit2allow -R
:
:
Comment 1 Miroslav Grepl 2012-03-01 06:54:27 EST

*** This bug has been marked as a duplicate of bug 798924 ***

Note You need to log in before you can comment on or make changes to this bug.