Bug 798926 - Not able to open Lotus Word Pro doc
Not able to open Lotus Word Pro doc
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libreoffice (Show other bugs)
6.3
s390x Linux
unspecified Severity medium
: rc
: ---
Assigned To: Caolan McNamara
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 04:46 EST by Tomas Pelka
Modified: 2013-10-03 20:29 EDT (History)
1 user (show)

See Also:
Fixed In Version: libreoffice-3.4.5.2-8.el6
Doc Type: Bug Fix
Doc Text:
Cause: Lotus Word Pro file format filter make little endian assumptions Consequence: File format filter nonfunctional on big endian platforms, e.g. s390x and powerpc Fix: implement byteswapping correctly Result: Functioning Lotus Word Pro filter on all supported architectures
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:53:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Lotus Word Pro example doc (22.63 KB, application/octet-stream)
2012-03-01 04:46 EST, Tomas Pelka
no flags Details

  None (edit)
Description Tomas Pelka 2012-03-01 04:46:18 EST
Created attachment 566797 [details]
Lotus Word Pro example doc

Description of problem:
SSIA

Version-Release number of selected component (if applicable):
libreoffice-writer-3.4.5.2-5.el6

How reproducible:
100%

Steps to Reproduce:
1. Open attached file
2.
3.
  
Actual results:
General Error. General Input/Output Error.

Expected results:
Should open the file.

Additional info:
Met it only on s390x, works fine on x86_64.
Comment 1 Caolan McNamara 2012-03-01 05:47:45 EST
s390x-only would be tricky, hopefully its a generic bigendian (+64bit) issue that I can replicate on a local ppc64
Comment 2 Tomas Pelka 2012-03-01 06:18:06 EST
ppc64 run in progress, cc-ing Vasiliy
Comment 3 Vasiliy Sharapov 2012-03-01 18:44:47 EST
This affects ppc64 as well.
Comment 4 Caolan McNamara 2012-03-02 05:54:28 EST
aha, yeah generic bigendian bug that I'd already fixed upstream for 3.5 onwards, just wasn't fixed in 3.4
Comment 7 Caolan McNamara 2012-05-01 06:05:52 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: Lotus Word Pro file format filter make little endian assumptions

Consequence: File format filter nonfunctional on big endian platforms, e.g. s390x and powerpc

Fix: implement byteswapping correctly

Result: Functioning Lotus Word Pro filter on all supported architectures
Comment 9 errata-xmlrpc 2012-06-20 08:53:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0798.html

Note You need to log in before you can comment on or make changes to this bug.