Bug 798979 - Ubuntu install CDs from oneiric onwards are not recognized: "multi-boot operating systems are not supported"
Ubuntu install CDs from oneiric onwards are not recognized: "multi-boot opera...
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 07:38 EST by Richard W.M. Jones
Modified: 2012-11-29 13:33 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-29 13:33:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2012-03-01 07:38:20 EST
Description of problem:

From oneiric onwards, the install CDs provided by Ubuntu show up
as multiple operating systems.  This is because the CD
contains the same filesystem on the whole device (eg. /dev/vda)
and on a partition (/dev/vda1):

><fs> dmesg | grep vda1
[    1.309559]  vda: vda1
><fs> file /dev/vda
# ISO 9660 CD-ROM filesystem data 'Ubuntu-Server 12.04 LTS amd64   ' (bootable)
><fs> file /dev/vda1 
# ISO 9660 CD-ROM filesystem data 'Ubuntu-Server 12.04 LTS amd64   '
><fs> list-filesystems 
/dev/vda1: iso9660
><fs> mount-ro /dev/vda /
><fs> umount /
><fs> mount-ro /dev/vda1 /
><fs> umount /
><fs> vfs-type /dev/vda
iso9660
><fs> vfs-type /dev/vda1
iso9660

Version-Release number of selected component (if applicable):

1.17.8
kernel 3.3.0-0.rc2.git4.1.fc17.x86_64

How reproducible:

100%

Steps to Reproduce:
1. virt-inspector -a ubuntu.iso | grep '<operatingsystem>' | wc -l
  
Actual results:

It displays '1' for Ubuntu < oneiric, and '2' for Ubuntu >= oneiric.

Expected results:

It should display '1'.

Additional info:
Comment 1 Richard W.M. Jones 2012-11-23 11:47:35 EST
Should be using libosinfo data to identify install CDs.

Note You need to log in before you can comment on or make changes to this bug.