Bug 799024 - aeolus-configure -p vsphere fails with invalid parameter for username/password
aeolus-configure -p vsphere fails with invalid parameter for username/password
Status: CLOSED NOTABUG
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.0.0
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Mike Orazi
wes hayutin
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 10:32 EST by Martin Kočí
Modified: 2012-03-01 11:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-01 11:07:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kočí 2012-03-01 10:32:53 EST
Description of problem:
if you try to run aeolus-configure for vsphere with configured password/username in aeolus_configure file then it fails. 

Version-Release number of selected component (if applicable):
# rpm -q aeolus-configure
aeolus-configure-2.5.0-16.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. configure /etc/aeolus-configure/nodes/vsphere_configure with password and username
2. run aeolus-configure -p vshpere

  
Actual results:
configure failed

Expected results:
configure passed

Additional info:
with version aeolus-configure-2.5.0-15.el6.noarch it works
Comment 1 Martin Kočí 2012-03-01 10:34:40 EST
[root@dell-pe1950-03 ~]# aeolus-configure -p vsphere
Launching aeolus configuration recipe...
Invalid parameter password on node dell-pe1950-03.rhts.englab.brq.redhat.com

# aeolus-configure -p vsphere
Launching aeolus configuration recipe...
Invalid parameter username on node dell-pe1950-03.rhts.englab.brq.redhat.com

# rpm -qa|grep 'aeolus\|imagefactory-\|oz-\|iwhd'
imagefactory-jeosconf-ec2-fedora-1.0.0rc8-1.el6.noarch
aeolus-conductor-0.8.0-39.el6.noarch
iwhd-1.2-3.el6.x86_64
rubygem-imagefactory-console-0.4.0-1.el6.noarch
rubygem-aeolus-cli-0.3.0-11.el6.noarch
oz-0.8.0-5.el6.noarch
aeolus-conductor-doc-0.8.0-39.el6.noarch
rubygem-aeolus-image-0.3.0-10.el6.noarch
aeolus-all-0.8.0-39.el6.noarch
imagefactory-1.0.0rc8-1.el6.noarch
aeolus-configure-2.5.0-16.el6.noarch
imagefactory-jeosconf-ec2-rhel-1.0.0rc8-1.el6.noarch
aeolus-conductor-daemons-0.8.0-39.el6.noarch
Comment 2 wes hayutin 2012-03-01 11:07:41 EST
the design is to no longer include the creds in the file

Note You need to log in before you can comment on or make changes to this bug.