This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 799025 - JBoss SOA-P 5.0 ESB missing method org.jboss.soa.esb.dom.YADOMUtil.getCommentBefore(Lorg/w3c/dom/Element;)Lorg/w3c/dom/Comment; due to old JBoss ESB version
JBoss SOA-P 5.0 ESB missing method org.jboss.soa.esb.dom.YADOMUtil.getComment...
Status: CLOSED NOTABUG
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.0.0 GA
Unspecified Linux
unspecified Severity low
: ---
: ---
Assigned To: Kevin Conner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 10:43 EST by Adam Kovari
Modified: 2015-08-31 23:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-12 10:28:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Kovari 2012-03-01 10:43:57 EST
Description of problem:
org.jboss.soa.esb.dom.YADOMUtil does not contain method getCommentBefore(org.w3c.dom.Element element) but is called elsewhere in SOA-P. Please add this method into this class or update ESB version.

4.9 contains it:
http://docs.jboss.org/jbossesb/docs/4.9/javadoc/esb/org/jboss/soa/esb/dom/YADOMUtil.html

Customer's stacktrace:

2012-03-01 12:59:14,237 94476 ERROR [STDERR] (pool-24-thread-1:) javax.management.RuntimeErrorException
2012-03-01 12:59:14,238 94477 ERROR [STDERR] (pool-24-thread-1:) 	at org.jboss.mx.interceptor.ReflectedDispatcher.handleInvocationExceptions(ReflectedDispatcher.java:182)
2012-03-01 12:59:14,238 94477 ERROR [STDERR] (pool-24-thread-1:) 	at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:165)
2012-03-01 12:59:14,238 94477 ERROR [STDERR] (pool-24-thread-1:) 	at org.jboss.mx.server.Invocation.dispatch(Invocation.java:96)
2012-03-01 12:59:14,238 94477 ERROR [STDERR] (pool-24-thread-1:) 	at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
2012-03-01 12:59:14,239 94478 ERROR [STDERR] (pool-24-thread-1:) 	at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
2012-03-01 12:59:14,239 94478 ERROR [STDERR] (pool-24-thread-1:) 	at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:668)
2012-03-01 12:59:14,239 94478 ERROR [STDERR] (pool-24-thread-1:) 	at org.jboss.soa.esb.actions.soap.MBeanSoapUIInvoker.buildRequest(MBeanSoapUIInvoker.java:73)
2012-03-01 12:59:14,240 94479 ERROR [STDERR] (pool-24-thread-1:) 	at org.jboss.soa.esb.actions.soap.SOAPClient.process(SOAPClient.java:425)
2012-03-01 12:59:14,240 94479 ERROR [STDERR] (pool-24-thread-1:) 	at com.accarda.esb.settlementprocessorsv.ep2.services.SoapClientExtender.process(SoapClientExtender.java:45)
2012-03-01 12:59:14,240 94479 ERROR [STDERR] (pool-24-thread-1:) 	at org.jboss.soa.esb.listeners.message.ActionProcessingPipeline.processPipeline(ActionProcessingPipeline.java:635)
2012-03-01 12:59:14,240 94479 ERROR [STDERR] (pool-24-thread-1:) 	at org.jboss.soa.esb.listeners.message.ActionProcessingPipeline.processPipeline(ActionProcessingPipeline.java:589)
2012-03-01 12:59:14,241 94480 ERROR [STDERR] (pool-24-thread-1:) 	at org.jboss.soa.esb.listeners.message.ActionProcessingPipeline.process(ActionProcessingPipeline.java:419)
2012-03-01 12:59:14,241 94480 ERROR [STDERR] (pool-24-thread-1:) 	at org.jboss.soa.esb.listeners.message.MessageAwareListener$TransactionalRunner.run(MessageAwareListener.java:540)
2012-03-01 12:59:14,241 94480 ERROR [STDERR] (pool-24-thread-1:) 	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
2012-03-01 12:59:14,241 94480 ERROR [STDERR] (pool-24-thread-1:) 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
2012-03-01 12:59:14,241 94480 ERROR [STDERR] (pool-24-thread-1:) 	at java.lang.Thread.run(Unknown Source)
2012-03-01 12:59:14,242 94481 ERROR [STDERR] (pool-24-thread-1:) Caused by: java.lang.NoSuchMethodError: org.jboss.soa.esb.dom.YADOMUtil.getCommentBefore(Lorg/w3c/dom/Element;)Lorg/w3c/dom/Comment;
2012-03-01 12:59:14,242 94481 ERROR [STDERR] (pool-24-thread-1:) 	at org.jboss.soa.esb.services.soapui.SoapUIClientService.getClonePoint(SoapUIClientService.java:806)
2012-03-01 12:59:14,242 94481 ERROR [STDERR] (pool-24-thread-1:) 	at org.jboss.soa.esb.services.soapui.SoapUIClientService.expandMessage(SoapUIClientService.java:705)
2012-03-01 12:59:14,243 94482 ERROR [STDERR] (pool-24-thread-1:) 	at org.jboss.soa.esb.services.soapui.SoapUIClientService.buildSOAPMessage(SoapUIClientService.java:534)
2012-03-01 12:59:14,243 94482 ERROR [STDERR] (pool-24-thread-1:) 	at org.jboss.soa.esb.services.soapui.SoapUIClientService.buildRequest(SoapUIClientService.java:340)
2012-03-01 12:59:14,243 94482 ERROR [STDERR] (pool-24-thread-1:) 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
2012-03-01 12:59:14,243 94482 ERROR [STDERR] (pool-24-thread-1:) 	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
2012-03-01 12:59:14,243 94482 ERROR [STDERR] (pool-24-thread-1:) 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
2012-03-01 12:59:14,244 94483 ERROR [STDERR] (pool-24-thread-1:) 	at java.lang.reflect.Method.invoke(Unknown Source)
2012-03-01 12:59:14,244 94483 ERROR [STDERR] (pool-24-thread-1:) 	at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:157)
2012-03-01 12:59:14,244 94483 ERROR [STDERR] (pool-24-thread-1:) 	... 14 more


Version-Release number of selected component (if applicable):
JBoss SOA-P 5.0.1
JBoss ESB 4.7, 4.8

How reproducible:
Occurs in some cases when using web-service with ESB

Additional info:
This is fixed in newer SOA-P versions since they have newer ESB.
Comment 1 Rick Wagner 2012-03-01 11:15:04 EST
Note:  GSS is working with the customer, to see if this issue can be worked around.
Comment 2 Adam Kovari 2012-03-12 10:28:47 EDT
We found the reason for this issue, below .sar and .jars were missing in our JBOSS server. 
1.	deploy/soapui-client.sar. 
2.	deployers/esb.deployer/lib/jbossesb-rosetta.jar
3.	deployers/esb.deployer/lib/xbean-2.2.0.jar

Note You need to log in before you can comment on or make changes to this bug.