Bug 799058 - first attempt to login always fails after hitting the logout page
first attempt to login always fails after hitting the logout page
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity low
: beta
: ---
Assigned To: Angus Thomas
wes hayutin
https://qeblade30.rhq.lab.eng.bos.red...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 11:42 EST by wes hayutin
Modified: 2012-12-04 09:57 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The first attempt to login to Cloud Engine was failing after logging out. The error no longer occurs in the latest Cloud Engine RPMs
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 09:57:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2012-03-01 11:42:47 EST
Description of problem:

Not sure if we want to do anything about this.. but here's the info..

1. on a running conductor.. OPEN the following URL
https://host/conductor/logout
 
  * to be clear type in /conductor/logout

2. try to login

first attempt will *always* fail




Started GET "/conductor/logout" for 10.11.11.150 at Thu Mar 01 11:42:07 -0500 2012
  Processing by UserSessionsController#destroy as HTML
Redirected to https://qeblade30.rhq.lab.eng.bos.redhat.com/conductor/login
Completed 302 Found in 2ms


Started GET "/conductor/login" for 10.11.11.150 at Thu Mar 01 11:42:10 -0500 2012
  Processing by UserSessionsController#new as HTML
Rendered user_sessions/_security.html.haml (1.6ms)
Rendered user_sessions/new.html.haml within layouts/login (8.6ms)
Completed 200 OK in 10ms (Views: 9.7ms | ActiveRecord: 24.5ms)


Started POST "/conductor/user_session" for 10.11.11.150 at Thu Mar 01 11:42:21 -0500 2012
  Processing by UserSessionsController#create as JS
  Parameters: {"login"=>"admin", "password"=>"[FILTERED]", "authenticity_token"=>"nd8nm85fPjGx1ZsMHWUKsQNwqbxfMWTxIKv6Qx036Dg=", "utf8"=>"✓", "_password"=>"[FILTERED]"}
Warden is authenticating admin against database
  User Load (0.4ms)  SELECT "users".* FROM "users" WHERE "users"."login" = 'admin' LIMIT 1
  SQL (0.3ms)  BEGIN
  Quota Load (0.4ms)  SELECT "quotas".* FROM "quotas" WHERE "quotas"."id" = 4 LIMIT 1
  SQL (0.4ms)  SELECT 1 FROM "users" WHERE ("users"."login" = 'admin') AND ("users".id <> 1) LIMIT 1
  AREL (0.4ms)  UPDATE "users" SET "updated_at" = '2012-03-01 16:42:21.354049', "last_login_at" = '2012-03-01 16:42:21.000000', "login_count" = 33 WHERE "users"."id" = 1
  SQL (12.5ms)  COMMIT
Rendered text template (0.0ms)
Completed 201 Created in 129ms (Views: 0.8ms | ActiveRecord: 22.1ms)


Started GET "/conductor/logout" for 10.11.11.150 at Thu Mar 01 11:42:21 -0500 2012
  Processing by UserSessionsController#destroy as HTML
  User Load (5.9ms)  SELECT "users".* FROM "users" WHERE "users"."id" = 1 LIMIT 1
Redirected to https://qeblade30.rhq.lab.eng.bos.redhat.com/conductor/login
Completed 302 Found in 9ms


Started GET "/conductor/login" for 10.11.11.150 at Thu Mar 01 11:42:22 -0500 2012
  Processing by UserSessionsController#new as HTML
Rendered user_sessions/_security.html.haml (1.7ms)
Rendered user_sessions/new.html.haml within layouts/login (9.1ms)
Completed 200 OK in 11ms (Views: 10.1ms | ActiveRecord: 15.5ms)
Comment 4 pushpesh sharma 2012-09-18 09:19:14 EDT
This is not seems to be the case with the current build.First or any subsequent login after logout is successful with valid credentials.
 
Verified on:-
[root@dhcp201-113 ~]# rpm -qa|grep aeolus
aeolus-conductor-doc-0.13.7-1.el6cf.noarch
aeolus-all-0.13.7-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.13.7-1.el6cf.noarch
aeolus-conductor-daemons-0.13.7-1.el6cf.noarch
Comment 7 errata-xmlrpc 2012-12-04 09:57:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.