Bug 799077 - Evolution mail view shows garbage at the end of MIME-encoded text
Evolution mail view shows garbage at the end of MIME-encoded text
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 13:10 EST by Jonathan Briggs
Modified: 2012-03-02 05:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-02 05:56:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A message which causes Evolution to display badly (3.75 KB, application/mbox)
2012-03-01 13:10 EST, Jonathan Briggs
no flags Details
The actual message instead of Evolution' (3.87 KB, application/mbox)
2012-03-01 13:13 EST, Jonathan Briggs
no flags Details

  None (edit)
Description Jonathan Briggs 2012-03-01 13:10:42 EST
Created attachment 566904 [details]
A message which causes Evolution to display badly

Description of problem:
A message sent to the Linux kernel mailing list encoded in UTF-8 and MIME encoded is displayed with garbage at the end of the message. Also Evolution wants to download a font called N'Ko to display the garbage with.

The garbage is not actually in the message. Downloading the message source and MIME decoding with a different tool results in a clean message.

Version-Release number of selected component (if applicable):
Evolution 3.2.3

How reproducible:
Every time the message is viewed.

Steps to Reproduce:
1. View the attached message source in Evolution.
2. 
3.
  
Actual results:
The message ends with garbage like this: "Thanks.NrybXǧv^)޺{.n+{zXܨ}Ơz&j:+vzZ++zfh~izw?&)ߢf^jǫym@Aa0hi"


Expected results:
The message should end with "Thanks."


Additional info:
Comment 1 Jonathan Briggs 2012-03-01 13:13:59 EST
Created attachment 566905 [details]
The actual message instead of Evolution'
Comment 2 Jonathan Briggs 2012-03-01 13:15:07 EST
(In reply to comment #1)
> Created attachment 566905 [details]
> The actual message instead of Evolution'

This comment was meant to say: The actual message instead of Evolution's misguided attempt to decode it before saving.

On the plus side the first attachment shows the bad decoding.
Comment 3 Milan Crha 2012-03-02 05:56:08 EST
Thanks for a bug report. I'm afraid that this is not evolution's fault, but the list's fault. The message clearly states that its body is base64 encoded, but the list robot appends to it its signature unencoded, which is simple no-no. If they really want to have there their footer, then they should either add it as a new part, or respect sender's Content-Transfer-Encoding and Content-Type. I suppose nobody noticed this earlier, because sending text/plain message base64 encoded is rather rare.

Note You need to log in before you can comment on or make changes to this bug.