Bug 79909 - XFree86 Int10 module unusable on ZX1 PCI bridge
XFree86 Int10 module unusable on ZX1 PCI bridge
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: XFree86 (Show other bugs)
2.1
ia64 Linux
high Severity high
: ---
: ---
Assigned To: John Dennis
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-17 18:41 EST by John Fujii
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-13 18:28:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Int10 patch to replace current 8010 ATI patch in build. (3.91 KB, patch)
2002-12-17 18:43 EST, John Fujii
no flags Details | Diff

  None (edit)
Description John Fujii 2002-12-17 18:41:37 EST
Description of problem:
Previous release of Derry created ZX1-centric bits that Red Hat would like to
address for other I/O bridges.  Int10 module was not shipped with previous
release - other Intel architectures would like to use this.

John Dennis' XFree86 patch 8010 (XFree86-4.1.0-ati-skip-int10-on-hp-ia64.patch)
addresses Int10 support problems within the ATI Radeon but not for other drivers
that may access the Int10 module.

The proposed patch does not allow Int10 to be loaded on any ZX1 boxes for the
type being.  Int10 has proven to be problematic because card BIOS's on ZX1
sometimes trigger a hard failure.  While this may be related to the cachable/not
cachable memory issue elsewhere, we have fully confirm this yet.

A backdoor is provided for testing purposes (allow Int10 on ZX1 bridges).  The 
option is "true" for "INT10onZX1" (override the override).

Version-Release number of selected component (if applicable):
XFree86-4.1.0-41

How reproducible:
Using non-ATI drivers (like NV) or the VBE module can cause Int10 to load and
initialize.  Also, accelerated OEM drivers from ATI (X1/Z1) have also hung when
the Int10 module is loaded.

Steps to Reproduce:
    
Actual results:

Expected results:

Additional info:
Comment 1 John Fujii 2002-12-17 18:43:33 EST
Created attachment 88787 [details]
Int10 patch to replace current 8010 ATI patch in build.
Comment 2 John Fujii 2002-12-17 18:45:53 EST
Bug 79909 is also logged in Red Hat Issue Tracker as issue 12371.
Comment 3 Mike A. Harris 2002-12-19 02:01:23 EST
Red Hat OS Development engineering does not use Issue Tracker.  Issue tracker
is for client engineering, etc.   All bugs and defects and details about
those defects must be reported in bugzilla always, or Red Hat OS engineers
will never see them.  It is also preferred that the bug reporter is the
person who is able to reproduce an issue as it increases the two way
communication, and decreases time between status updates, and also lowers
the time from bug report to bug resolution.  As long as someone reports
it in bugzilla however, then Red Hat engineering will see it, be that
a technical contact on our side, or on the other side.  It is mission critical
however that all defects in all products be logged in bugzilla though.  Note
that this is not a change of policy, however there may have possibly been
some miscommunication between Red Hat and it's partners about this policy.
I hope this clarifies things a bit.

Thanks.
Comment 4 Tim Burke 2002-12-20 13:50:21 EST
Adding in some info I recieved from Daryl Poe in itemizing the set of graphics
cards that HP cares about:

Supported in the original release were:
Radeon 7000
Nvidia Quadro 2 EX
Nvidia Quadro 4 900 XGL

Hopefully the PCI ID will be added for:
Nvidia Quatdo 4 980 XGL

In the April or later timeframe:
ATI X1
ATI Z1

Red Hat has requested that HP send John Dennis one of each of these cards.
Comment 6 John Dennis 2002-12-24 11:24:06 EST
I have built a new package with the patch submitted by John Fujii and I'm 
testing it now. Initially there does seem to be a problem, the server is dying 
in a manner Glen Foster reported with package 42, but I was never able to 
reproduce. Investigating...
Comment 7 John Fujii 2003-01-07 14:18:32 EST
Any progress on this issue since 12/24?

---

With respect to the Nvidia 980 card XGL, I believe that it's
best to modify the NV Q4 patch already submitted and running
in AWS 2.1 XFree86 (at least for the XF86 part).  Besides the
PCI IDs, a change needs to be added to the initialization 
switch statement.  I've tried this and it works as expected.
A future card (NV 380) does not, however.  Investigating...
Comment 9 Mike A. Harris 2003-01-15 08:25:52 EST
The patch for this is in 4.1.0-44

Setting to MODIFIED state pending confirmation.
Comment 10 John Flanagan 2003-02-13 18:28:22 EST
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-019.html

Note You need to log in before you can comment on or make changes to this bug.