Bug 799123 - anaconda should detect liveCD installation
anaconda should detect liveCD installation
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
: Reopened
: 876852 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 15:06 EST by Bill Nottingham
Modified: 2014-03-16 23:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-21 11:45:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2012-03-01 15:06:35 EST
Description of problem:

If I hit the window close button on anaconda in the live environment, and confirm that I'd like to exit the installer, the live image reboots.

Version-Release number of selected component (if applicable):

20120229 live nightly.
anaconda-17.11-1
Comment 1 Nathanael Noblet 2012-03-23 16:16:29 EDT
Using TC1 I get a warning that this is pre-release software, if I click 'exit',  I get another dialogue box with 'Back' and 'Reboot'. I would expect to say I don't want to install and not have to reboot. anaconda-17.12-1
Comment 2 Bastien Nocera 2012-11-15 03:30:27 EST
*** Bug 876852 has been marked as a duplicate of this bug. ***
Comment 3 Bastien Nocera 2012-11-15 03:30:59 EST
Still happening in anaconda-18.28-1.fc18.x86_64
Comment 4 Brian Lane 2012-11-15 11:43:57 EST
How did you do this? There is no close button, and using 'Quit' from the main hub or 'Reboot' after a successful install doesn't reboot.
Comment 5 Bastien Nocera 2012-11-21 07:44:39 EST
Anaconda is too dumb to realise I'm using a live CD and breaks in various ways when called "anaconda" instead of "liveinst". That's one of the ways.
Comment 6 Chris Lumens 2012-11-21 10:49:33 EST
It takes various arguments to set up a live install.  That's why you run "liveinst" instead of "anaconda".  So, that's expected behavior we will not be changing.
Comment 7 Bastien Nocera 2012-11-21 11:41:38 EST
Why can't anaconda detect that it's being run from the live image and do the right thing?

There's not a single warning in the installer that it's not being run correctly.

I was told this was because anaconda developers do run anaconda by hand for testing. Surely, this would call for a "--im-an-anaconda-developer" flag rather than making people like me go down the rabbit hole and see bugs after bugs?
Comment 8 Chris Lumens 2012-11-21 11:45:03 EST
If you want to run the live installer from the live environment, you need to run the liveinst command.  That sets everything up for you, without needing to do any special work.  We already have too many ways of detecting the installation payload and we're not going to add any more, certainly not more that duplicate functionality that already exists.

Running anaconda from the command line to begin with is not encouraged.
Comment 9 Nathanael Noblet 2012-11-21 12:03:32 EST
Just my 2 cents. I had the same issue - though I wasn't running 'anaconda' rom the command line. I was using a live CD. However I've just tested Beta 18 RC1 and didn't do that anymore.

Note You need to log in before you can comment on or make changes to this bug.