Bug 799157 - gparted can not create logicala partition
gparted can not create logicala partition
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gparted (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 17:20 EST by Flóki Pálsson
Modified: 2013-02-22 11:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-22 11:49:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Flóki Pálsson 2012-03-01 17:20:32 EST
Description of problem:
gparted can not create logicala partition.

Version-Release number of selected component (if applicable):
gparted-0.12.0-1.fc17.x86_64


How reproducible:
always 

Steps to Reproduce:
1. select unalocated in extended partition ( /dev/sdc4 )
2.
3.
  
Actual results:
GParted 0.12.0 --enable-libparted-dmraid

Libparted 3.0
Create Logical Partition #1 (ext4, 23.49 GiB) on /dev/sdc  00:00:08    ( ERROR )
     	
create empty partition  00:00:04    ( SUCCESS )
     	
path: /dev/sdc19
start: 675,772,416
end: 725,043,199
size: 49,270,784 (23.49 GiB)
set partition type on /dev/sdc19  00:00:03    ( SUCCESS )
     	
new partition type: ext4
create new ext4 file system  00:00:01    ( ERROR )
     	
mkfs.ext4 -j -O extent -L "vara" /dev/sdc19
     	
mke2fs 1.42 (29-Nov-2011)
Could not stat /dev/sdc19 --- No such file or directory

The device apparently does not exist; did you specify it correctly?

========================================


Expected results:
A new partition

Additional info:

I could create partition with F14.
Comment 1 Curtis Gedak 2012-03-02 11:38:13 EST
The root cause of this error is that the underlying components of the operating system did not create the device entry /dev/sdc19.

In theory you can have an infinite number of logical partitions.  Having said that, the operating system only supports creating device entries for a limited number of these.  For many GNU/Linux distributions, this limit is 15 logical partitions.

The GParted FAQ contains information on this limitation:
What is the maximum amount of logical partitions an extended partition can hold?
http://gparted.org/faq.php#faq-8

To confirm which partition device entries have been created, you can try listing these with the 'ls' command:

     ls -l /dev/sdc*

In conclusion, if the underlying GNU/Linux distribution supports more than 15 logical partitions, then so does GParted.
Comment 2 Curtis Gedak 2012-03-18 12:22:37 EDT
A patch to permit more than 16 partitions has been included in (lib)parted 3.1.

See "libparted: raise dos partition limit from 16 to 64" in the release notes.

parted-3.1 released [stable]
http://lists.gnu.org/archive/html/info-gnu/2012-03/msg00001.html
Comment 3 Flóki Pálsson 2012-05-13 13:08:43 EDT
The error is still in F17.
gparted-0.12.0-2.fc17.x86_64



GParted 0.12.0 --enable-libparted-dmraid

Libparted 3.0
Create Logical Partition #1 (ext4, 29.18 GiB) on /dev/sdb  00:00:06    ( ERROR )
     	
create empty partition  00:00:03    ( SUCCESS )
     	
path: /dev/sdb18
start: 620,908,544
end: 682,100,735
size: 61,192,192 (29.18 GiB)
set partition type on /dev/sdb18  00:00:03    ( SUCCESS )
     	
new partition type: ext4
create new ext4 file system  00:00:00    ( ERROR )
     	
mkfs.ext4 -j -O extent -L "sdb18" /dev/sdb18
     	
mke2fs 1.42 (29-Nov-2011)
Could not stat /dev/sdb18 --- No such file or directory

The device apparently does not exist; did you specify it correctly?
Comment 4 Curtis Gedak 2012-05-13 15:33:27 EDT
From the log file I can see that libparted 3.0 is being used.

The fix for this problem is included in libparted 3.1.  I believe that parted/libparted 3.1 has been packaged for inclusion in F18.

Note You need to log in before you can comment on or make changes to this bug.