Bug 799182 - [WHQL][Block]Job of "Sleep Stress with IO" and Common Scenario Stress with IO" always failed on winxp/win2k3 for invalid block address.
[WHQL][Block]Job of "Sleep Stress with IO" and Common Scenario Stress with IO...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 22:32 EST by dawu
Modified: 2014-07-11 02:46 EDT (History)
9 users (show)

See Also:
Fixed In Version: build 24
Doc Type: Bug Fix
Doc Text:
No Documentation needed. Sort time regression introduced while switching uniform virtio library.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 07:58:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sleep_Stress_With_IO_xp.wsf.wtl (1.15 MB, application/octet-stream)
2012-03-01 22:33 EST, dawu
no flags Details

  None (edit)
Description dawu 2012-03-01 22:32:09 EST
Description of problem:
Job of "Sleep Stress with IO" and Common Scenario Stress with IO" always failed on winxp/win2k3 for invalid block address.

Version-Release number of selected component (if applicable):
virtio-win-prewhql-0.1-23
kernel-2.6.32-232.el6.x86_64
qemu-kvm-0.12.1.2-2.227.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. Run job "Sleep Stress with IO"/"Common Scenario Stress with IO".
2. Run sub-job "Execute Sleep_Stress_with_IO"/"Execute Common_Scenario_Stress_with_IO"

Actual results:
Sub job failed with the invalid block address,following is the DTM logs:
--------------------------------------------------------------------------------
Title Result 
  Failed 
 Start Test 2/27/2012 4:32:05.843 PM Devices and the System as a whole must continue to function before and after Sleep Cycles. {ADCBD1A0-16E8-11DB-B50B-0010C65AFEB5} 
Message 2/27/2012 4:32:05.843 PM Test Version: 1.0.0003 
Message 2/27/2012 4:32:06.843 PM Devices: 'IsPhantom=False AND IsRootEnumerated=False AND ClassGUID!='{533C5B84-EC70-11D2-9505-00C04F79DEAF}' AND parent/service!=swenum AND (above-or-self/(DeviceID='PCI\VEN_1AF4&DEV_1001&SUBSYS_00021AF4&REV_00\3&13C0B0C5&0&28' OR Service='viostor' OR Filters='viostor'))' 
Message 2/27/2012 4:32:06.843 PM MinutesToRun: 30 
Message 2/27/2012 4:32:06.843 PM CyclesToRun: 12 
Message 2/27/2012 4:32:06.843 PM SleepPeriod: 60 
Message 2/27/2012 4:32:06.843 PM MinIOPeriod: 1 sec 
Message 2/27/2012 4:32:06.843 PM MaxIOPeriod: 20 sec 
Message 2/27/2012 4:32:06.843 PM ResumeDelay: 10 sec 
Message 2/27/2012 4:32:06.843 PM RandomSeed: 0.17143 
Message 2/27/2012 4:32:06.843 PM Start Time: Mon Feb 27 16:32:06 UTC+0800 2012 
Message 2/27/2012 4:32:06.843 PM Earliest End Time: Mon Feb 27 17:02:06 UTC+0800 2012 
Message 2/27/2012 4:32:07.843 PM Attempting to find a SimpleIOStress implementation for each related test device. 
End Test 2/27/2012 5:03:00.843 PM Devices and the System as a whole must continue to function before and after Sleep Cycles. {ADCBD1A0-16E8-11DB-B50B-0010C65AFEB5} 
Result:   Fail 
 
  Failed 
 Start Test 2/27/2012 4:32:56.843 PM B(2) - The device and system must pass this cycle of Sleep Stress with IO. {0BDD5D91-DCE3-4859-BB72-5457B89BF176} 
End Test 2/27/2012 4:33:26.843 PM B(2) - The device and system must pass this cycle of Sleep Stress with IO. {0BDD5D91-DCE3-4859-BB72-5457B89BF176} 
Result:   Fail 
 
  Failed 
 Start Test 2/27/2012 4:33:12.843 PM B(2).2 - The device and system must go to sleep fully and then wake automatically. {ADCBD1E6-16E8-11DB-B50B-0010C65AFEB5} 
Message 2/27/2012 4:33:12.843 PM Time: Mon Feb 27 16:33:12 UTC+0800 2012 
Message 2/27/2012 4:33:12.843 PM SleepPeriod: 60 seconds 
Message 2/27/2012 4:33:12.843 PM Sleep State: S4 
Error 2/27/2012 4:33:16.843 PM SetSleepState() failed! -> Unable to put the system on standby using SetSuspendState(...). HRESULT=0x0 - The operation completed successfully.  
File:   . Line: 0 
Error Type:   HRESULT 
Error Code:   0x9 
Error Text:   The storage control block address is invalid. 
End Test 2/27/2012 4:33:26.843 PM B(2).2 - The device and system must go to sleep fully and then wake automatically. {ADCBD1E6-16E8-11DB-B50B-0010C65AFEB5} 
Result:   Fail 
--------------------------------------------------------------------------------

Expected results:
Job should passed without any error.

Additional info:
This issue reproduced on winxp and win2k3,please refer to the attachment "Sleep_Stress_With_IO_xp.wsf.wtl" and "winxp-blk-23-fail-AD.cpk" for details.
Comment 1 dawu 2012-03-01 22:33:14 EST
Created attachment 566984 [details]
Sleep_Stress_With_IO_xp.wsf.wtl
Comment 2 dawu 2012-03-01 22:34:05 EST
Created attachment 566985 [details]
winxp-blk-23-fail-AD.cpk
Comment 3 Ronen Hod 2012-03-04 12:32:25 EST
Is this a sequential log? If it is, then what is the time "5:03:00" doing in between the "4:32:"
Comment 5 Vadim Rozenfeld 2012-03-18 17:42:12 EDT
Please check with the latest drivers from:
http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/24/win/virtio-win-prewhql-0.1.zip
Comment 6 dawu 2012-03-26 02:04:39 EDT
Verified this issue with the latest build virtio-win-prewhql-0.1-24,following is 
the environment details:

virtio-win-prewhql-0.1-24
kernel-2.6.32-232.el6.x86_64
qemu-kvm-0.12.1.2-2.227.el6.x86_64

Job "Sleep Stress with IO" and Common Scenario Stress with IO" passed without any error.

Best Regards,
Dawn
Comment 7 Vadim Rozenfeld 2012-03-26 04:26:57 EDT
(In reply to comment #6)
> Verified this issue with the latest build virtio-win-prewhql-0.1-24,following
> is 
> the environment details:
> 
> virtio-win-prewhql-0.1-24
> kernel-2.6.32-232.el6.x86_64
> qemu-kvm-0.12.1.2-2.227.el6.x86_64
> 
> Job "Sleep Stress with IO" and Common Scenario Stress with IO" passed without
> any error.
> 
> Best Regards,
> Dawn

Hi Dawn,
It's a good news,
Many thank for your affords and updates.

Best,
Vadim.
Comment 10 Vadim Rozenfeld 2012-05-03 07:13:06 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No Documentation needed.
Sort time regression introduced while switching uniform 
virtio library.
Comment 11 errata-xmlrpc 2012-06-20 07:58:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0751.html

Note You need to log in before you can comment on or make changes to this bug.