Bug 799254 - Existed app with cron embeded missed .openshift/cron directory after stage is upgraded
Existed app with cron embeded missed .openshift/cron directory after stage i...
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
1.x
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-02 04:33 EST by Xiaoli Tian
Modified: 2012-03-02 04:46 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-02 04:46:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaoli Tian 2012-03-02 04:33:05 EST
Description of problem:
Had embedded cron to an app before stage was upgraded,and check cron status after stage was upgraded,got the following messages:
"
Application has no scheduled jobs
 - Missing .openshift/cron/ directory.
cron scheduling service is enabled
"
ssh to the app and found .openshift/cron missed.


Version-Release number of selected component (if applicable):
Stage
rhc-cartridge-cron-1.4-0.3.1-1.el6_2.noarch

How reproducible:
Always

Steps to Reproduce:
1.Embed an cron to an  app in stage before it's upgraded
2.Check cron status after stage is upgraded

  
Actual results:
Directory .openshift/cron is missed

Expected results:
The directory should be existed

Additional info:

I have tried this by manually upgrading devenv-stage_136 to the latest ,not met this issue.
Comment 1 Xiaoli Tian 2012-03-02 04:46:07 EST
Since it's because my app is too old , maybe created before cron is released,and the directory could be added manually by user, let me close this bug.

Note You need to log in before you can comment on or make changes to this bug.