Bug 799271 - Usage: subscription-manager service-level [OPTIONS]
Usage: subscription-manager service-level [OPTIONS]
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-03-02 05:45 EST by Shwetha Kallesh
Modified: 2012-06-20 09:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:06:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shwetha Kallesh 2012-03-02 05:45:04 EST
Description of problem:

help message of subscription-manager service-levels is displaying wrong command name

Version-Release number of selected component (if applicable):

[root@dhcp201-166 pki]# rpm -qa | grep subscription-manager
subscription-manager-gnome-0.99.8-1.el6.x86_64
subscription-manager-0.99.8-1.el6.x86_64
subscription-manager-migration-0.99.8-1.el6.x86_64
subscription-manager-migration-data-1.12-1.el6.noarch
subscription-manager-debuginfo-0.99.8-1.el6.x86_64


How reproducible:


Steps to Reproduce:
[root@dhcp201-166 pki]# subscription-manager service-levels --help
Usage: subscription-manager service-level [OPTIONS]
                            ^^^ should be "service-levels"

 
Display the service levels available for an organization.

If I try with command service-level,I get the following message

[root@dhcp201-166 pki]# subscription-manager service-level --list


Usage: subscription-manager [options] MODULENAME --help


Primary Modules:

	list           List subscription and product information for this machine


  
Actual results:


Expected results:


Additional info:
Comment 4 John Sefler 2012-03-05 15:05:27 EST
Please undo commit in comment #2

dgoodwin and I settled on "subscription-manager service-level" without the "s" because the default option behavior for subscription-manager service-level is to "--show" which displays the consumer's current service level.  Hence the singular form of "subscription-manager service-level" makes the most sense and returns the same value as "subscription-manager service-level --show".
Comment 6 Shwetha Kallesh 2012-03-06 01:31:16 EST
Moving to verified..

RPM used:

[root@dhcp201-162 ~]# rpm -qa | grep subscription-manager
subscription-manager-0.99.8-1.git.16.f7ed3d6.el6.x86_64
subscription-manager-migration-0.99.8-1.git.16.f7ed3d6.el6.x86_64
subscription-manager-firstboot-0.99.8-1.git.16.f7ed3d6.el6.x86_64
subscription-manager-migration-data-1.12.1-1.git.4.7b6cf92.el6.noarch
subscription-manager-gnome-0.99.8-1.git.16.f7ed3d6.el6.x86_64
subscription-manager-debuginfo-0.99.8-1.el6.x86_64

[root@dhcp201-162 ~]# subscription-manager service-level --help
Usage: subscription-manager service-level [OPTIONS]

Manage service levels for this system.
Comment 8 errata-xmlrpc 2012-06-20 09:06:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.