Bug 799299 - growisofs cannot write twice to a TEAC DV-W28SS-R (fix = apply specified patch)
growisofs cannot write twice to a TEAC DV-W28SS-R (fix = apply specified patch)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dvd+rw-tools (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Honza Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-02 07:38 EST by Reartes Guillermo
Modified: 2012-05-03 18:52 EDT (History)
1 user (show)

See Also:
Fixed In Version: dvd+rw-tools-7.1-9.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-02 16:50:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg, prior to test (73.79 KB, text/plain)
2012-03-02 07:40 EST, Reartes Guillermo
no flags Details
dmesg after test (73.79 KB, text/plain)
2012-03-02 07:41 EST, Reartes Guillermo
no flags Details
blktrace, first burn (compressed due to size) (368.32 KB, application/x-gzip)
2012-03-02 07:43 EST, Reartes Guillermo
no flags Details
blktrace, second (the one that does not start) burn (compressed due to size) (824.58 KB, application/x-gzip)
2012-03-02 07:44 EST, Reartes Guillermo
no flags Details
blktrace of the first and second burn with a TEAC on 990FX with JMicron Controller (980.26 KB, application/x-gzip)
2012-03-02 13:46 EST, Reartes Guillermo
no flags Details
dmesg, sb990fx, pre test (102.84 KB, text/plain)
2012-03-02 13:47 EST, Reartes Guillermo
no flags Details
dmesg, sb990fx, post tests (113.90 KB, text/plain)
2012-03-02 13:48 EST, Reartes Guillermo
no flags Details
blktrace, sb990fx, JMicron controller, SAMSUNG USB (toshiba) usb writer wich perform the two burns ok (925.69 KB, application/x-gzip)
2012-03-02 13:50 EST, Reartes Guillermo
no flags Details
blktrace of the first and second burn with a TEAC on 990FX with AMD Controller (1.03 MB, application/x-gzip)
2012-03-02 14:07 EST, Reartes Guillermo
no flags Details
dmesg, sb990fx, AMD controller, post tests (108.88 KB, text/plain)
2012-03-02 14:08 EST, Reartes Guillermo
no flags Details
blktrace of the first and second burn with a iHBS112 on 990FX with AMD Controller (916.78 KB, application/x-gzip)
2012-03-02 14:37 EST, Reartes Guillermo
no flags Details
patched transport.hxx file (57.62 KB, text/plain)
2012-03-06 15:41 EST, Reartes Guillermo
no flags Details
patch proposed to upstream (783 bytes, patch)
2012-03-07 09:57 EST, Honza Horak
no flags Details | Diff

  None (edit)
Description Reartes Guillermo 2012-03-02 07:38:19 EST
Description of problem:

It happens with any media i tried, dvd+r, dvd-r, dvd-rw.
I ended testing only with dvd+rw to avoid wasting to many media.

I can issue only one write operation to the TEAC drive.

Version-Release number of selected component (if applicable):

OS: F17a, 3.3.0-0.rc5.git3.1.fc17.x86_64
SW: dvd+rw-tools.x86_64 ----> 7.1-6.fc17

How reproducible:
allways

Steps to Reproduce:
1. put a blank dvd (dvd+r, dvd-r, dvd+rw)
2. issue a growisofs command (for example dvd+rw, growisofs -Z /dev/sr0 -R -J /foo/1/)
3. write is succesfull
4 eject and reinsert the disk
5 issue another growisofs -M /dev/sr0 -R -J /foo/2/
6 the write never starts. to perform the desired action, one has to either power-cycle or remove and replug the writer to the sata controller.

Actual results:
that teac (i have more than one) cannot write twice

i have other non-teac (samsung/toshiba) usb writer and it works correctly.

Expected results:
teac should work as good as the samsung writer (and any other normal writer).

Additional info:

here: http://lists.debian.org/cdwrite/2010/10/msg00005.html
somebody mentions a pach for this specific writer, but i am unable to know if it has been already applied or not.

It happens with opensuse 12.1, and centos 5.7 and f17a, of course.

HW MOBO: ASUS M4N72-E
HW SATA: SATA controller [0106]: nVidia Corporation MCP78S [GeForce 8200] AHCI Controller [10de:0ad4] (rev a2)

The writer is a SATA unit.
Comment 1 Reartes Guillermo 2012-03-02 07:39:49 EST
# blktrace -d /dev/sr0 -o - | blkparse -i - &>f17a-teac-first.00.out &
[1] 987

# growisofs -Z /dev/sr0 -R -J /root/prueba/1/
WARNING: /dev/sr0 already carries isofs!
About to execute 'mkisofs -R -J /root/prueba/1/ | builtin_dd of=/dev/sr0 obs=32k seek=0'
I: -input-charset not specified, using utf-8 (detected in locale settings)
  3.92% done, estimate finish Fri Mar  2 09:14:15 2012
/dev/sr0: "Current Write Speed" is 4.1x1352KBps.
  7.85% done, estimate finish Fri Mar  2 09:16:09 2012
 11.76% done, estimate finish Fri Mar  2 09:15:48 2012
 15.68% done, estimate finish Fri Mar  2 09:15:44 2012
 19.59% done, estimate finish Fri Mar  2 09:15:36 2012
 23.52% done, estimate finish Fri Mar  2 09:15:31 2012
 27.43% done, estimate finish Fri Mar  2 09:15:31 2012
 31.35% done, estimate finish Fri Mar  2 09:15:28 2012
 35.26% done, estimate finish Fri Mar  2 09:15:28 2012
 39.19% done, estimate finish Fri Mar  2 09:15:26 2012
 43.10% done, estimate finish Fri Mar  2 09:15:26 2012
 47.02% done, estimate finish Fri Mar  2 09:15:25 2012
 50.93% done, estimate finish Fri Mar  2 09:15:25 2012
 54.86% done, estimate finish Fri Mar  2 09:15:24 2012
 58.77% done, estimate finish Fri Mar  2 09:15:24 2012
 62.69% done, estimate finish Fri Mar  2 09:15:23 2012
 66.60% done, estimate finish Fri Mar  2 09:15:24 2012
 70.52% done, estimate finish Fri Mar  2 09:15:23 2012
 74.44% done, estimate finish Fri Mar  2 09:15:22 2012
 78.36% done, estimate finish Fri Mar  2 09:15:22 2012
 82.27% done, estimate finish Fri Mar  2 09:15:21 2012
 86.19% done, estimate finish Fri Mar  2 09:15:22 2012
 90.11% done, estimate finish Fri Mar  2 09:15:21 2012
 94.03% done, estimate finish Fri Mar  2 09:15:22 2012
 97.94% done, estimate finish Fri Mar  2 09:15:21 2012
Total translation table size: 0
Total rockridge attributes bytes: 249
Total directory bytes: 0
Path table size(bytes): 10
Max brk space used 0
127636 extents written (249 MB)
builtin_dd: 127648*2KB out @ average 2.7x1352KBps
/dev/sr0: flushing cache
/dev/sr0: stopping de-icing
/dev/sr0: writing lead-out

# kill %1
# 
[1]+  Done                    blktrace -d /dev/sr0 -o - | blkparse -i - &>f17a-teac-first.00.out

# eject

# blktrace -d /dev/sr0 -o - | blkparse -i - &>f17a-teac-second.00.out &
[1] 1003

#  growisofs -M /dev/sr0 -R -J /root/prueba/2/
Executing 'mkisofs -C 16,127648 -M /dev/fd/3 -R -J /root/prueba/2/ | builtin_dd of=/dev/sr0 obs=32k seek=7978'
I: -input-charset not specified, using utf-8 (detected in locale settings)
Rock Ridge signatures found
 50.93% done, estimate finish Fri Mar  2 09:17:03 2012
 52.89% done, estimate finish Fri Mar  2 09:17:03 2012
^C

# kill %1
# 
[1]+  Done                    blktrace -d /dev/sr0 -o - | blkparse -i - &>f17a-teac-second.00.out
Comment 2 Reartes Guillermo 2012-03-02 07:40:33 EST
Created attachment 567046 [details]
dmesg, prior to test
Comment 3 Reartes Guillermo 2012-03-02 07:41:33 EST
Created attachment 567047 [details]
dmesg after test
Comment 4 Reartes Guillermo 2012-03-02 07:43:13 EST
Created attachment 567048 [details]
blktrace, first burn (compressed due to size)
Comment 5 Reartes Guillermo 2012-03-02 07:44:29 EST
Created attachment 567049 [details]
blktrace, second (the one that does not start) burn (compressed due to size)
Comment 6 Reartes Guillermo 2012-03-02 13:45:14 EST
I tested again in another motherboard.

HW SATA: SATA controller [0106]: JMicron Technology Corp. JMB362 AHCI Controller [197b:2362] (rev 10)
HW MOBO: ASUS SABERTOOTH 990FX (Has both AMD and JMicron SATA controllers)
OS: F17a, 3.3.0-0.rc5.git3.1.fc17.x86_64

HW WRITER: DV-W28SS-R

I tested two TEAC writers, in this test i used a single blktrace.

# blktrace -d /dev/sr0 -o - | blkparse -i - &>f17a-teac-990fx-jmc-first_and_second.00.out &
[1] 1248
[root@localhost ~]# growisofs -Z /dev/sr0 -R -J /root/test/1/
WARNING: /dev/sr0 already carries isofs!
About to execute 'mkisofs -R -J /root/test/1/ | builtin_dd of=/dev/sr0 obs=32k seek=0'
I: -input-charset not specified, using utf-8 (detected in locale settings)
  3.22% done, estimate finish Fri Mar  2 15:25:28 2012
/dev/sr0: "Current Write Speed" is 4.1x1352KBps.
  6.44% done, estimate finish Fri Mar  2 15:27:32 2012
  9.66% done, estimate finish Fri Mar  2 15:27:21 2012
 12.88% done, estimate finish Fri Mar  2 15:27:08 2012
 16.09% done, estimate finish Fri Mar  2 15:27:01 2012
 19.31% done, estimate finish Fri Mar  2 15:27:01 2012
 22.52% done, estimate finish Fri Mar  2 15:26:56 2012
 25.75% done, estimate finish Fri Mar  2 15:26:57 2012
 28.96% done, estimate finish Fri Mar  2 15:26:54 2012
 32.18% done, estimate finish Fri Mar  2 15:26:55 2012
 35.39% done, estimate finish Fri Mar  2 15:26:52 2012
 38.61% done, estimate finish Fri Mar  2 15:26:53 2012
 41.83% done, estimate finish Fri Mar  2 15:26:51 2012
 45.05% done, estimate finish Fri Mar  2 15:26:52 2012
 48.26% done, estimate finish Fri Mar  2 15:26:50 2012
 51.48% done, estimate finish Fri Mar  2 15:26:51 2012
 54.69% done, estimate finish Fri Mar  2 15:26:50 2012
 57.92% done, estimate finish Fri Mar  2 15:26:49 2012
 61.13% done, estimate finish Fri Mar  2 15:26:49 2012
 64.35% done, estimate finish Fri Mar  2 15:26:48 2012
 67.56% done, estimate finish Fri Mar  2 15:26:49 2012
 70.79% done, estimate finish Fri Mar  2 15:26:48 2012
 74.00% done, estimate finish Fri Mar  2 15:26:49 2012
 77.22% done, estimate finish Fri Mar  2 15:26:48 2012
 80.43% done, estimate finish Fri Mar  2 15:26:48 2012
 83.65% done, estimate finish Fri Mar  2 15:26:48 2012
 86.87% done, estimate finish Fri Mar  2 15:26:48 2012
 90.09% done, estimate finish Fri Mar  2 15:26:52 2012
 93.30% done, estimate finish Fri Mar  2 15:26:51 2012
 96.52% done, estimate finish Fri Mar  2 15:26:50 2012
 99.73% done, estimate finish Fri Mar  2 15:26:50 2012
Total translation table size: 0
Total rockridge attributes bytes: 248
Total directory bytes: 0
Path table size(bytes): 10
Max brk space used 0
155421 extents written (303 MB)
builtin_dd: 155424*2KB out @ average 2.7x1352KBps
/dev/sr0: flushing cache
/dev/sr0: stopping de-icing
/dev/sr0: writing lead-out
[root@localhost ~]# 
[root@localhost ~]# 
[root@localhost ~]# eject
[root@localhost ~]# growisofs -M /dev/sr0 -R -J /root/test/2/
Executing 'mkisofs -C 16,155424 -M /dev/fd/3 -R -J /root/test/2/ | builtin_dd of=/dev/sr0 obs=32k seek=9714'
I: -input-charset not specified, using utf-8 (detected in locale settings)
Rock Ridge signatures found
 51.48% done, estimate finish Fri Mar  2 15:28:30 2012
^C
[root@localhost ~]# kill %1


Since i noticed that something was still being outputed by blktrace, i launched it again after aborting the second growisofs.

[root@localhost ~]# blktrace -d /dev/sr0 -o - | blkparse -i - 
 11,0    2        1     0.000000000    41  G   N [kworker/2:1]
 11,0    2        2     0.000110553    41  I   R 8 (4a 01 00 00 10 00 00 00 08 00 ..) [kworker/2:1]
 11,0    2        3     0.000112233    41  D   R 8 (4a 01 00 00 10 00 00 00 08 00 ..) [kworker/2:1]
 11,0    4        1     0.002358368     0  C   R (4a 01 00 00 10 00 00 00 08 00 ..) [0]
 11,0    2        4     2.047987272    41  G   N [kworker/2:1]
 11,0    2        5     2.048096913    41  I   R 8 (4a 01 00 00 10 00 00 00 08 00 ..) [kworker/2:1]
 11,0    2        6     2.048098243    41  D   R 8 (4a 01 00 00 10 00 00 00 08 00 ..) [kworker/2:1]
 11,0    5        1     2.050323090     0  C   R (4a 01 00 00 10 00 00 00 08 00 ..) [0]
 11,0    2        7     4.096040341    41  G   N [kworker/2:1]
 11,0    2        8     4.096149099    41  I   R 8 (4a 01 00 00 10 00 00 00 08 00 ..) [kworker/2:1]
 11,0    2        9     4.096150411    41  D   R 8 (4a 01 00 00 10 00 00 00 08 00 ..) [kworker/2:1]
 11,0    4        2     4.098690154  1311  C   R (4a 01 00 00 10 00 00 00 08 00 ..) [0]
 11,0    2       10     6.144001070    41  G   N [kworker/2:1]
 11,0    2       11     6.144111464    41  I   R 8 (4a 01 00 00 10 00 00 00 08 00 ..) [kworker/2:1]
 11,0    2       12     6.144112773    41  D   R 8 (4a 01 00 00 10 00 00 00 08 00 ..) [kworker/2:1]
 11,0    4        3     6.146337252     0  C   R (4a 01 00 00 10 00 00 00 08 00 ..) [0]
^CCPU2 (11,0):
 Reads Queued:           0,        0KiB  Writes Queued:           0,        0KiB
 Read Dispatches:        0,        0KiB  Write Dispatches:        0,        0KiB
 Reads Requeued:         0               Writes Requeued:         0
 Reads Completed:        0,        0KiB  Writes Completed:        0,        0KiB
 Read Merges:            0,        0KiB  Write Merges:            0,        0KiB
 Read depth:             1               Write depth:             0
 PC Reads Queued:        0,        0KiB  PC Writes Queued:        0,        0KiB
 PC Read Disp.:          4,        0KiB  PC Write Disp.:          0,        0KiB
 PC Reads Req.:          0               PC Writes Req.:          0
 PC Reads Compl.:        0               PC Writes Compl.:        0
 IO unplugs:             0               Timer unplugs:           0
CPU4 (11,0):
 Reads Queued:           0,        0KiB  Writes Queued:           0,        0KiB
 Read Dispatches:        0,        0KiB  Write Dispatches:        0,        0KiB
 Reads Requeued:         0               Writes Requeued:         0
 Reads Completed:        0,        0KiB  Writes Completed:        0,        0KiB
 Read Merges:            0,        0KiB  Write Merges:            0,        0KiB
 Read depth:             1               Write depth:             0
 PC Reads Queued:        0,        0KiB  PC Writes Queued:        0,        0KiB
 PC Read Disp.:          0,        0KiB  PC Write Disp.:          0,        0KiB
 PC Reads Req.:          0               PC Writes Req.:          0
 PC Reads Compl.:        3               PC Writes Compl.:        0
 IO unplugs:             0               Timer unplugs:           0
CPU5 (11,0):
 Reads Queued:           0,        0KiB  Writes Queued:           0,        0KiB
 Read Dispatches:        0,        0KiB  Write Dispatches:        0,        0KiB
 Reads Requeued:         0               Writes Requeued:         0
 Reads Completed:        0,        0KiB  Writes Completed:        0,        0KiB
 Read Merges:            0,        0KiB  Write Merges:            0,        0KiB
 Read depth:             1               Write depth:             0
 PC Reads Queued:        0,        0KiB  PC Writes Queued:        0,        0KiB
 PC Read Disp.:          0,        0KiB  PC Write Disp.:          0,        0KiB
 PC Reads Req.:          0               PC Writes Req.:          0
 PC Reads Compl.:        1               PC Writes Compl.:        0
 IO unplugs:             0               Timer unplugs:           0

Total (11,0):
 Reads Queued:           0,        0KiB  Writes Queued:           0,        0KiB
 Read Dispatches:        0,        0KiB  Write Dispatches:        0,        0KiB
 Reads Requeued:         0               Writes Requeued:         0
 Reads Completed:        0,        0KiB  Writes Completed:        0,        0KiB
 Read Merges:            0,        0KiB  Write Merges:            0,        0KiB
 PC Reads Queued:        0,        0KiB  PC Writes Queued:        0,        0KiB
 PC Read Disp.:          4,        0KiB  PC Write Disp.:          0,        0KiB
 PC Reads Req.:          0               PC Writes Req.:          0
 PC Reads Compl.:        4               PC Writes Compl.:        0
 IO unplugs:             0               Timer unplugs:           0

Throughput (R/W): 0KiB/s / 0KiB/s
Events (11,0): 16 entries
Skips: 0 forward (0 -   0.0%)
[1]+  Done                    blktrace -d /dev/sr0 -o - | blkparse -i - &>f17a-teac-990fx-jmc-first_and_second.00.out

Of course, the samsung_toshiba_usb writer performed ok.
Comment 7 Reartes Guillermo 2012-03-02 13:46:52 EST
Created attachment 567128 [details]
blktrace of the first and second burn with a TEAC on 990FX with JMicron Controller
Comment 8 Reartes Guillermo 2012-03-02 13:47:37 EST
Created attachment 567129 [details]
dmesg, sb990fx, pre test
Comment 9 Reartes Guillermo 2012-03-02 13:48:10 EST
Created attachment 567130 [details]
dmesg, sb990fx, post tests
Comment 10 Reartes Guillermo 2012-03-02 13:50:46 EST
Created attachment 567132 [details]
blktrace, sb990fx, JMicron controller, SAMSUNG USB (toshiba) usb writer wich perform the two burns ok
Comment 11 Reartes Guillermo 2012-03-02 14:06:14 EST
I tested again, but with the SABERTOOTH 990FX and the:
* SATA controller [0106]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode] [1002:4391] (rev 40)

Same result.

# blktrace -d /dev/sr0 -o - | blkparse -i - &>f17a-teac-990fx-amd-first_and_second.00.out &
[1] 1295

[root@localhost ~]# growisofs -Z /dev/sr0 -R -J /root/test/1/
WARNING: /dev/sr0 already carries isofs!
About to execute 'mkisofs -R -J /root/test/1/ | builtin_dd of=/dev/sr0 obs=32k seek=0'
I: -input-charset not specified, using utf-8 (detected in locale settings)
  3.22% done, estimate finish Fri Mar  2 15:57:11 2012
/dev/sr0: "Current Write Speed" is 4.1x1352KBps.
  6.44% done, estimate finish Fri Mar  2 15:59:15 2012
  9.66% done, estimate finish Fri Mar  2 15:59:04 2012
 12.88% done, estimate finish Fri Mar  2 15:58:51 2012
 16.09% done, estimate finish Fri Mar  2 15:58:50 2012
 19.31% done, estimate finish Fri Mar  2 15:58:44 2012
 22.52% done, estimate finish Fri Mar  2 15:58:39 2012
 25.75% done, estimate finish Fri Mar  2 15:58:40 2012
 28.96% done, estimate finish Fri Mar  2 15:58:37 2012
 32.18% done, estimate finish Fri Mar  2 15:58:38 2012
 35.39% done, estimate finish Fri Mar  2 15:58:35 2012
 38.61% done, estimate finish Fri Mar  2 15:58:36 2012
 41.83% done, estimate finish Fri Mar  2 15:58:34 2012
 45.05% done, estimate finish Fri Mar  2 15:58:35 2012
 48.26% done, estimate finish Fri Mar  2 15:58:33 2012
 51.48% done, estimate finish Fri Mar  2 15:58:34 2012
 54.69% done, estimate finish Fri Mar  2 15:58:33 2012
 57.92% done, estimate finish Fri Mar  2 15:58:33 2012
 61.13% done, estimate finish Fri Mar  2 15:58:32 2012
 64.35% done, estimate finish Fri Mar  2 15:58:33 2012
 67.56% done, estimate finish Fri Mar  2 15:58:32 2012
 70.79% done, estimate finish Fri Mar  2 15:58:31 2012
 74.00% done, estimate finish Fri Mar  2 15:58:32 2012
 77.22% done, estimate finish Fri Mar  2 15:58:31 2012
 80.43% done, estimate finish Fri Mar  2 15:58:31 2012
 83.65% done, estimate finish Fri Mar  2 15:58:31 2012
 86.87% done, estimate finish Fri Mar  2 15:58:31 2012
 90.09% done, estimate finish Fri Mar  2 15:58:36 2012
 93.30% done, estimate finish Fri Mar  2 15:58:34 2012
 96.52% done, estimate finish Fri Mar  2 15:58:33 2012
 99.73% done, estimate finish Fri Mar  2 15:58:33 2012
Total translation table size: 0
Total rockridge attributes bytes: 248
Total directory bytes: 0
Path table size(bytes): 10
Max brk space used 0
155421 extents written (303 MB)
builtin_dd: 155424*2KB out @ average 2.7x1352KBps
/dev/sr0: flushing cache
/dev/sr0: stopping de-icing
/dev/sr0: writing lead-out

[root@localhost ~]# eject /dev/sr0 

[root@localhost ~]# growisofs -M /dev/sr0 -R -J /root/test/2/
Executing 'mkisofs -C 16,155424 -M /dev/fd/3 -R -J /root/test/2/ | builtin_dd of=/dev/sr0 obs=32k seek=9714'
I: -input-charset not specified, using utf-8 (detected in locale settings)
Rock Ridge signatures found
 51.48% done, estimate finish Fri Mar  2 15:59:39 2012
^C

[root@localhost ~]# eject
[root@localhost ~]# kill %1
[root@localhost ~]# 
[1]+  Done                    blktrace -d /dev/sr0 -o - | blkparse -i - &>f17a-teac-990fx-amd-first_and_second.00.out
Comment 12 Reartes Guillermo 2012-03-02 14:07:48 EST
Created attachment 567140 [details]
blktrace of the first and second burn with a TEAC on 990FX with AMD Controller
Comment 13 Reartes Guillermo 2012-03-02 14:08:32 EST
Created attachment 567141 [details]
dmesg, sb990fx, AMD controller, post tests
Comment 14 Reartes Guillermo 2012-03-02 14:37:20 EST
Created attachment 567149 [details]
blktrace of the first and second burn with a iHBS112 on 990FX with AMD Controller

I tested a SATA BluRay iHBS112 on the AMD controller and it works ok. Only the TEAC (actually i have more than one, all have the issue).

# growisofs -Z /dev/sr0 -R -J /root/test/1/
WARNING: /dev/sr0 already carries isofs!
About to execute 'mkisofs -R -J /root/test/1/ | builtin_dd of=/dev/sr0 obs=32k seek=0'
I: -input-charset not specified, using utf-8 (detected in locale settings)
  3.22% done, estimate finish Fri Mar  2 16:28:06 2012
/dev/sr0: "Current Write Speed" is 4.1x1352KBps.
  6.44% done, estimate finish Fri Mar  2 16:30:25 2012
  9.66% done, estimate finish Fri Mar  2 16:29:49 2012
 12.88% done, estimate finish Fri Mar  2 16:29:39 2012
 16.09% done, estimate finish Fri Mar  2 16:29:33 2012
 19.31% done, estimate finish Fri Mar  2 16:29:28 2012
 22.52% done, estimate finish Fri Mar  2 16:29:25 2012
 25.75% done, estimate finish Fri Mar  2 16:29:19 2012
 28.96% done, estimate finish Fri Mar  2 16:29:18 2012
 32.18% done, estimate finish Fri Mar  2 16:29:17 2012
 35.39% done, estimate finish Fri Mar  2 16:29:16 2012
 38.61% done, estimate finish Fri Mar  2 16:29:15 2012
 41.83% done, estimate finish Fri Mar  2 16:29:15 2012
 45.05% done, estimate finish Fri Mar  2 16:29:12 2012
 48.26% done, estimate finish Fri Mar  2 16:29:12 2012
 51.48% done, estimate finish Fri Mar  2 16:29:12 2012
 54.69% done, estimate finish Fri Mar  2 16:29:11 2012
 57.92% done, estimate finish Fri Mar  2 16:29:11 2012
 61.13% done, estimate finish Fri Mar  2 16:29:11 2012
 64.35% done, estimate finish Fri Mar  2 16:29:11 2012
 67.56% done, estimate finish Fri Mar  2 16:29:09 2012
 70.79% done, estimate finish Fri Mar  2 16:29:09 2012
 74.00% done, estimate finish Fri Mar  2 16:29:09 2012
 77.22% done, estimate finish Fri Mar  2 16:29:09 2012
 80.43% done, estimate finish Fri Mar  2 16:29:09 2012
 83.65% done, estimate finish Fri Mar  2 16:29:09 2012
 86.87% done, estimate finish Fri Mar  2 16:29:09 2012
 90.09% done, estimate finish Fri Mar  2 16:29:08 2012
 93.30% done, estimate finish Fri Mar  2 16:29:08 2012
 96.52% done, estimate finish Fri Mar  2 16:29:08 2012
 99.73% done, estimate finish Fri Mar  2 16:29:08 2012
Total translation table size: 0
Total rockridge attributes bytes: 248
Total directory bytes: 0
Path table size(bytes): 10
Max brk space used 0
155421 extents written (303 MB)
builtin_dd: 155424*2KB out @ average 3.5x1352KBps
/dev/sr0: flushing cache
/dev/sr0: stopping de-icing
/dev/sr0: writing lead-out
[root@localhost ~]# eject /dev/sr0
[root@localhost ~]# growisofs -M /dev/sr0 -R -J /root/test/2/
Executing 'mkisofs -C 16,155424 -M /dev/fd/3 -R -J /root/test/2/ | builtin_dd of=/dev/sr0 obs=32k seek=9714'
I: -input-charset not specified, using utf-8 (detected in locale settings)
Rock Ridge signatures found
 51.48% done, estimate finish Fri Mar  2 16:30:20 2012
/dev/sr0: "Current Write Speed" is 4.1x1352KBps.
 53.08% done, estimate finish Fri Mar  2 16:30:25 2012
 54.69% done, estimate finish Fri Mar  2 16:30:30 2012
 56.30% done, estimate finish Fri Mar  2 16:30:34 2012
 57.91% done, estimate finish Fri Mar  2 16:30:37 2012
 59.52% done, estimate finish Fri Mar  2 16:30:41 2012
 61.13% done, estimate finish Fri Mar  2 16:30:44 2012
 62.73% done, estimate finish Fri Mar  2 16:30:47 2012
 64.35% done, estimate finish Fri Mar  2 16:30:49 2012
 65.95% done, estimate finish Fri Mar  2 16:30:50 2012
 67.56% done, estimate finish Fri Mar  2 16:30:52 2012
 69.17% done, estimate finish Fri Mar  2 16:30:54 2012
 70.78% done, estimate finish Fri Mar  2 16:30:56 2012
 72.39% done, estimate finish Fri Mar  2 16:30:58 2012
 74.00% done, estimate finish Fri Mar  2 16:31:00 2012
 75.60% done, estimate finish Fri Mar  2 16:31:02 2012
 77.21% done, estimate finish Fri Mar  2 16:31:02 2012
 78.82% done, estimate finish Fri Mar  2 16:31:04 2012
 80.43% done, estimate finish Fri Mar  2 16:31:06 2012
 82.04% done, estimate finish Fri Mar  2 16:31:07 2012
 83.65% done, estimate finish Fri Mar  2 16:31:09 2012
 85.25% done, estimate finish Fri Mar  2 16:31:10 2012
 86.86% done, estimate finish Fri Mar  2 16:31:10 2012
 88.47% done, estimate finish Fri Mar  2 16:31:11 2012
 90.08% done, estimate finish Fri Mar  2 16:31:13 2012
 91.69% done, estimate finish Fri Mar  2 16:31:14 2012
 93.30% done, estimate finish Fri Mar  2 16:31:15 2012
 94.90% done, estimate finish Fri Mar  2 16:31:16 2012
 96.52% done, estimate finish Fri Mar  2 16:31:18 2012
 98.12% done, estimate finish Fri Mar  2 16:31:18 2012
 99.73% done, estimate finish Fri Mar  2 16:31:19 2012
Total translation table size: 0
Total rockridge attributes bytes: 328
Total directory bytes: 0
Path table size(bytes): 10
Max brk space used 0
310845 extents written (607 MB)
builtin_dd: 155424*2KB out @ average 3.6x1352KBps
/dev/sr0: flushing cache
/dev/sr0: copying volume descriptor(s)
/dev/sr0: flushing cache
/dev/sr0: stopping de-icing
/dev/sr0: writing lead-out
[root@localhost ~]# 
[root@localhost ~]# 
[root@localhost ~]# eject
[root@localhost ~]# kill %1
[root@localhost ~]# 
[1]+  Done                    blktrace -d /dev/sr0 -o - | blkparse -i - &>f17a-iHBS112-990fx-amd-first_and_second.00.out
Comment 15 Reartes Guillermo 2012-03-06 09:19:53 EST
I can confirm that 'the other os' (xp + nero latest nero trial) does not have this issue.
Comment 16 Reartes Guillermo 2012-03-06 11:58:13 EST
I can also corfirm that both Fedora 17a updated and CentOS 5.7 updated with nerolinux 4.0.0.0b does not suffer from the issue.

It seems to be growisofs specific.
Comment 17 Reartes Guillermo 2012-03-06 15:41:05 EST
Created attachment 568063 [details]
patched transport.hxx file

I needed add:

#include <limits.h>

after patching the file -by hand- to avoid a compiler error.

I tested the patch rebuilding dvd+rw-tools under Slackware64 13.37.
Slackware64 was also affected by the issue.

With the patch growisofs is able to perform the second write 
for dvd+rw, dvd-r, dvd+r.
Comment 18 Honza Horak 2012-03-07 09:57:52 EST
Created attachment 568318 [details]
patch proposed to upstream

Thanks for analyses and the patch. Please, try the following scratch build, if it fixes the issue:
http://koji.fedoraproject.org/koji/taskinfo?taskID=3863954
Comment 19 Reartes Guillermo 2012-03-07 12:54:38 EST
Tested with dvd+rw-tools-7.1-7.fc17.x86_64 on F17a (updated) and growisofs 
now can write more that one time to the teac writer without reboot or hot-swap.

Please note that CentOS 5.7 is also affected, so it is RHEL5.

Thanks for the package.
Comment 20 Fedora Update System 2012-03-19 07:20:22 EDT
dvd+rw-tools-7.1-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dvd+rw-tools-7.1-7.fc17
Comment 21 Fedora Update System 2012-03-20 02:05:52 EDT
Package dvd+rw-tools-7.1-7.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dvd+rw-tools-7.1-7.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4234/dvd+rw-tools-7.1-7.fc17
then log in and leave karma (feedback).
Comment 22 Fedora Update System 2012-04-06 09:09:28 EDT
dvd+rw-tools-7.1-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dvd+rw-tools-7.1-8.fc17
Comment 23 Fedora Update System 2012-04-06 09:12:48 EDT
dvd+rw-tools-7.1-8.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/dvd+rw-tools-7.1-8.fc16
Comment 24 Fedora Update System 2012-04-06 09:13:48 EDT
dvd+rw-tools-7.1-8.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/dvd+rw-tools-7.1-8.fc15
Comment 25 Fedora Update System 2012-05-02 16:50:31 EDT
dvd+rw-tools-7.1-9.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 26 Fedora Update System 2012-05-03 18:50:55 EDT
dvd+rw-tools-7.1-9.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Fedora Update System 2012-05-03 18:52:29 EDT
dvd+rw-tools-7.1-9.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.