Bug 799306 - User quota not enforced for multi-instance deployment
User quota not enforced for multi-instance deployment
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity high
: beta4
: ---
Assigned To: Jozef Zigmund
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-02 07:54 EST by Aziza Karol
Modified: 2012-05-15 18:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 18:48:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
quota1 (221.41 KB, image/png)
2012-03-02 07:55 EST, Aziza Karol
no flags Details
quota2 (223.59 KB, image/png)
2012-03-02 07:56 EST, Aziza Karol
no flags Details

  None (edit)
Description Aziza Karol 2012-03-02 07:54:39 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
i set user quota in such a way that only 2 out of 3 instances should launched.
however all the 3 instances got launched.

see attached screenshot.
  


Expected results:
user quota should be enforced for multi-instance deployment


Additional info:
rpm -qa | grep aeolus
aeolus-conductor-doc-0.8.0-39.el6.noarch
rubygem-aeolus-cli-0.3.0-12.el6.noarch
aeolus-all-0.8.0-39.el6.noarch
aeolus-conductor-0.8.0-39.el6.noarch
rubygem-aeolus-image-0.3.0-11.el6.noarch
aeolus-configure-2.5.0-16.el6.noarch
aeolus-conductor-daemons-0.8.0-39.el6.noarch
Comment 1 Aziza Karol 2012-03-02 07:55:17 EST
Created attachment 567052 [details]
quota1
Comment 2 Aziza Karol 2012-03-02 07:56:02 EST
Created attachment 567053 [details]
quota2
Comment 4 Jozef Zigmund 2012-03-06 08:48:18 EST
Patch of bugfix was posted:
https://fedorahosted.org/pipermail/aeolus-devel/2012-March/009422.html
Comment 5 Jozef Zigmund 2012-03-06 12:37:24 EST
Bugfix was pushed with commit # d26e63b412335dca945023310219b43c3daefd38, please verify it.
Comment 7 Rehana 2012-03-07 08:22:26 EST
verified on
[root@intel-d3c69-01 ~]# rpm -qa | grep aeolus
aeolus-conductor-doc-0.8.0-41.el6.noarch
aeolus-configure-2.5.0-18.el6.noarch
aeolus-conductor-daemons-0.8.0-41.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.0-13.el6.noarch
aeolus-all-0.8.0-41.el6.noarch
aeolus-conductor-0.8.0-41.el6.noarch

note:

None of the instance will come up if the application blueprint has instance more than the user quota.
Comment 9 errata-xmlrpc 2012-05-15 18:48:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0583.html

Note You need to log in before you can comment on or make changes to this bug.