Bug 799309 - Inconsistency between Modeshape configuration and documentation (Guvnor)
Inconsistency between Modeshape configuration and documentation (Guvnor)
Status: CLOSED DUPLICATE of bug 781166
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: doc-BRMS_Administrator_Guide (Show other bugs)
BRMS 5.3.0.GA
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: lcarlon
: Documentation
Depends On:
  Show dependency treegraph
Reported: 2012-03-02 08:00 EST by Sona Mala
Modified: 2012-03-04 20:26 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-03-04 20:26:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Sona Mala 2012-03-02 08:00:10 EST
Description of problem:
After instalation of Modeshape according to Administrator_Guide, Guvnor, that is oppenned by browser, failed with:
     HTTP Status 404 - /jboss-brms/org.drools.guvnor.Guvnor/Guvnor.jsp

Version-Release number of selected component (if applicable):
brms standalone 5.3.0.ER4

How reproducible:
Important for reproduction this error is set in jboss-brms.war/WEB-INF/components.xml 

<property name="properties">
<key>org.modeshape.jcr.URL</key>                 <value>jndi:jcr/local?repositoryName=brms</value>

and go to http://localhost:8080/jboss-brms/
Actual results:

HTTP Status 404 - /jboss-brms/

Expected results:
login form

Additional info:
Everything is ok when I use repositoryName=jcrrepo, how is set in standalone/modeshape/resources/modeshape-config-brms.xml:

<!-- Specify the source that should be used for the repository -->
<mode:repository jcr:name="jcrrepo" >
Comment 1 lcarlon 2012-03-04 20:26:15 EST
Thanks Sona,

This is a recent update to modeshape, I'm in the process of update the doc, however the changes won't be visible on docs.redhat.com until we publish the 5.3 docs.


*** This bug has been marked as a duplicate of bug 781166 ***

Note You need to log in before you can comment on or make changes to this bug.