Bug 799357 - Problems importing manifest with beta3 drop
Problems importing manifest with beta3 drop
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Garik Khachikyan
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-02 10:06 EST by scollier
Modified: 2015-01-04 16:59 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 14:56:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
katello-debug (138.97 KB, application/x-gzip)
2012-03-02 10:06 EST, scollier
no flags Details
screenshot of nil error (111.04 KB, image/png)
2012-03-02 10:07 EST, scollier
no flags Details
new katello-debug - second server reproduction (220.16 KB, application/x-gzip)
2012-03-09 09:51 EST, scollier
no flags Details

  None (edit)
Description scollier 2012-03-02 10:06:14 EST
Created attachment 567085 [details]
katello-debug

Description of problem:

on a clean install of host and beta3 SE code, get the following error when importing manifest:

undefined method `include?' for nil:NilClass


Version-Release number of selected component (if applicable):

# /pub/scripts/post_install_configuration_scripts/cf-se-versions 
Red Hat Enterprise Linux Server release 6.2 (Santiago)
Linux cf-se2.cloud.lab.eng.bos.redhat.com 2.6.32-220.4.2.el6.x86_64 #1 SMP Mon Feb 6 16:39:28 EST 2012 x86_64 x86_64 x86_64 GNU/Linux
PyYAML-3.09-14.el6_1.x86_64
facter-1.5.9-1.el6.noarch
js-1.8.5-6.el6.x86_64
mongodb-1.8.2-3.el6.x86_64
mongodb-server-1.8.2-3.el6.x86_64
puppet-2.6.11-1.el6_1.noarch
pymongo-1.9-8.el6_1.x86_64
tomcat6-6.0.24-35.el6_1.noarch
ruby-1.8.7.352-6.el6.x86_64
grinder-0.0.139-1.el6.noarch
postgresql-server-8.4.9-1.el6_1.1.x86_64
postgresql-8.4.9-1.el6_1.1.x86_64
candlepin-0.5.23-1.el6.noarch
pulp-1.0.0-4.el6.noarch
katello-0.1.301-2.el6.noarch
katello-all-0.1.301-2.el6.noarch
katello-cli-0.1.100-2.el6.noarch
katello-configure-0.1.101-1.el6.noarch


How reproducible:

always.  right now the server is in a broken state.

Steps to Reproduce:
1.  download a manifest from access.redhat.com
2. try to import it.
3.
  
Actual results:

got the nil error reported above

Expected results:

manifest would import and i can enable repos

Additional info:

i'm attaching a screenshot of the error and a katello-debug tar file.
Comment 1 scollier 2012-03-02 10:07:37 EST
Created attachment 567086 [details]
screenshot of nil error
Comment 8 scollier 2012-03-09 09:50:24 EST
i was able to reproduce the error on a different system.  If you want to log in, just ping me and i'll provide info.  Attaching new katello-debug output for new system.
Comment 9 scollier 2012-03-09 09:51:48 EST
Created attachment 568916 [details]
new katello-debug - second server reproduction
Comment 13 scollier 2012-03-14 11:20:02 EDT
generated a new manifest.  was able to import that manifest.  i must have messed up the cert on the last one after i made a change.
Comment 14 Brad Buckingham 2012-03-14 11:55:39 EDT
Reassigning to investigate the issue with the UI error message.
Comment 15 Brad Buckingham 2012-03-15 11:12:19 EDT
commit - 2faa2b4be162975ae20cc937c8c5bf78d1699fc7

This initial commit addresses the "undefined method `include?' for nil:NilClass" error that was previously created.  Replacing it is a standard error message indicating that the import failed with the stack trace of the failure stored in the optional notice details.  (This stack trace may be useful in providing to support when such errors occur.)

At this time, the specific reason for the failure is not available to the UI controller; therefore, it cannot be shown. Discussed with Ivan and he mentioned that he will look at exposing more details from the backend.  Will modify the current behavior, when those details are available; however, this commit will address the initial error.
Comment 17 Ivan Necas 2012-03-19 12:52:40 EDT
commit f103d3efd5265d30cf0de85ce7b56be348e5e03b

provide descriptive information on CDN access denied

When imported manifest is not valid and CDN refuses it, UI and CLI provides
more descriptive information about what happened.
Comment 19 Garik Khachikyan 2012-03-21 07:37:07 EDT
# VERIFIED

so far doing manifest imports succeeds both on CFSE & Katello.

Recent beta5 is also performing good. checked against katello:
---
mod_wsgi-3.3-3.pulp.el6.x86_64
katello-common-0.2.15-1.git.0.16f633a.el6.noarch
pulp-selinux-server-1.0.0-6.el6.noarch
katello-repos-testing-0.2.1-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
candlepin-0.5.26-1.el6.noarch
candlepin-tomcat6-0.5.26-1.el6.noarch
katello-certs-tools-1.1.3-1.el6.noarch
qpid-cpp-server-0.12-6.el6.x86_64
katello-glue-foreman-0.2.15-1.git.0.16f633a.el6.noarch
katello-0.2.15-1.git.0.16f633a.el6.noarch
qpid-cpp-client-ssl-0.12-6.el6.x86_64
qpid-cpp-server-ssl-0.12-6.el6.x86_64
katello-cli-common-0.2.15-1.git.0.821013f.el6.noarch
katello-cli-0.2.15-1.git.0.821013f.el6.noarch
m2crypto-0.21.1.pulp-7.el6.x86_64
python-oauth2-1.5.170-2.pulp.el6.noarch
pulp-common-1.0.0-6.el6.noarch
qpid-cpp-client-0.12-6.el6.x86_64
katello-glue-pulp-0.2.15-1.git.0.16f633a.el6.noarch
katello-selinux-0.2.3-1.git.57.6c5edb8.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-agent-1.0.3-1.git.0.cccd0b4.el6.noarch
katello-cli-tests-0.2.5-1.git.0.58ae4b6.el6.noarch
python-qpid-0.12-1.el6.noarch
katello-glue-candlepin-0.2.15-1.git.0.16f633a.el6.noarch
pulp-1.0.0-6.el6.noarch
katello-repos-0.2.1-1.el6.noarch
katello-configure-0.2.15-1.git.4.94aa90a.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
---
Comment 20 errata-xmlrpc 2012-05-15 14:56:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0665.html
Comment 21 Mike McCune 2013-08-16 14:16:53 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.