Bug 799378 - SELinux is preventing /usr/sbin/logrotate from 'getattr' accesses on the file /var/spool/vscan/var/log/sagator/sagator.log.
SELinux is preventing /usr/sbin/logrotate from 'getattr' accesses on the file...
Status: CLOSED DUPLICATE of bug 799377
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:5895196f59a8ba57d973fee7b0e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-02 10:39 EST by geminic86
Modified: 2012-03-02 14:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-02 14:52:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description geminic86 2012-03-02 10:39:54 EST
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.2.7-1.fc16.i686.PAE
reason:         SELinux is preventing /usr/sbin/logrotate from 'getattr' accesses on the file /var/spool/vscan/var/log/sagator/sagator.log.
time:           Fri 02 Mar 2012 10:39:43 AM EST

description:
:SELinux is preventing /usr/sbin/logrotate from 'getattr' accesses on the file /var/spool/vscan/var/log/sagator/sagator.log.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that logrotate should be allowed getattr access on the sagator.log file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep logrotate /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:logrotate_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:sagator_var_t:s0
:Target Objects                /var/spool/vscan/var/log/sagator/sagator.log [
:                              file ]
:Source                        logrotate
:Source Path                   /usr/sbin/logrotate
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           logrotate-3.8.0-3.fc16.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-75.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.2.7-1.fc16.i686.PAE #1 SMP Tue Feb
:                              21 01:30:59 UTC 2012 i686 i686
:Alert Count                   2
:First Seen                    Fri 02 Mar 2012 10:38:13 AM EST
:Last Seen                     Fri 02 Mar 2012 10:38:13 AM EST
:Local ID                      b94dfeb9-2669-47d2-a650-c48e298cbc6b
:
:Raw Audit Messages
:type=AVC msg=audit(1330702693.819:394): avc:  denied  { getattr } for  pid=7509 comm="logrotate" path="/var/spool/vscan/var/log/sagator/sagator.log" dev=dm-1 ino=1710641 scontext=system_u:system_r:logrotate_t:s0-s0:c0.c1023 tcontext=system_u:object_r:sagator_var_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1330702693.819:394): arch=i386 syscall=stat64 success=no exit=EACCES a0=8ed29e8 a1=bf882074 a2=4f5ddff4 a3=bf882074 items=0 ppid=7507 pid=7509 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=7 comm=logrotate exe=/usr/sbin/logrotate subj=system_u:system_r:logrotate_t:s0-s0:c0.c1023 key=(null)
:
:Hash: logrotate,logrotate_t,sagator_var_t,file,getattr
:
:audit2allow
:
:#============= logrotate_t ==============
:allow logrotate_t sagator_var_t:file getattr;
:
:audit2allow -R
:
:#============= logrotate_t ==============
:allow logrotate_t sagator_var_t:file getattr;
:
Comment 1 Daniel Walsh 2012-03-02 14:52:27 EST

*** This bug has been marked as a duplicate of bug 799377 ***

Note You need to log in before you can comment on or make changes to this bug.