Bug 799394 - subscription-manager clean throws error when manage_repos is set to 0
subscription-manager clean throws error when manage_repos is set to 0
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Alex Wood
Entitlement Bugs
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-03-02 11:23 EST by Shwetha Kallesh
Modified: 2012-06-20 09:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:06:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shwetha Kallesh 2012-03-02 11:23:47 EST
Description of problem:

subscription-manager clean throws error when manage_repos  is set to 1 

Version-Release number of selected component (if applicable):

rpm -qa | grep subscription-manager 
subscription-manager-firstboot-0.99.8-1.git.14.9d78e7f.el6.x86_64
subscription-manager-migration-data-1.12.1-1.git.4.7b6cf92.el6.noarch
subscription-manager-gnome-0.99.8-1.git.14.9d78e7f.el6.x86_64
subscription-manager-debuginfo-0.99.8-1.el6.x86_64
subscription-manager-0.99.8-1.git.14.9d78e7f.el6.x86_64
subscription-manager-migration-0.99.8-1.git.14.9d78e7f.el6.x86_64


How reproducible:


Steps to Reproduce:
1.“add "manage_repos = 0" to the [rhsm] section of /etc/rhsm/rhsm.conf”
2.Restart rhsmcertd 
3.Register the client
4.execute subscription-manager clean
  
Actual results:
[Errno 2] No such file or directory: '/etc/yum.repos.d/redhat.repo' "
> ,.


Expected results:

Should say "All local data removed"

Additional info:
Comment 2 Alex Wood 2012-03-06 09:15:17 EST
Committed 91add3eddf9e796c6b1494d9e0b524c96886251c

subscription-manager-0.99.9+
Comment 4 Shwetha Kallesh 2012-03-08 07:08:57 EST
Moving to verified..

RPM Used:

[root@dhcp201-162 ~]# rpm -qa | grep subscription-manager
subscription-manager-migration-0.99.9-1.git.1.1ffc81e.el6.x86_64
subscription-manager-gnome-0.99.9-1.git.1.1ffc81e.el6.x86_64
subscription-manager-0.99.9-1.git.1.1ffc81e.el6.x86_64
subscription-manager-firstboot-0.99.9-1.git.1.1ffc81e.el6.x86_64
subscription-manager-migration-data-1.12.2-1.git.0.ede4958.el6.noarch
subscription-manager-debuginfo-0.99.9-1.el6.x86_64


[root@dhcp201-162 ~]# subscription-manager config --rhsm.manage_repos=0
[root@dhcp201-162 ~]# cat /etc/rhsm/rhsm.conf | grep manage_repos
manage_repos =0

[root@dhcp201-162 ~]# subscription-manager clean
All local data removed
Comment 6 errata-xmlrpc 2012-06-20 09:06:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.