Bug 799495 - RH repo creation fails [RHUI upgrade]
RH repo creation fails [RHUI upgrade]
Status: CLOSED DUPLICATE of bug 799497
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.0.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jay Dobies
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-02 14:20 EST by Kedar Bidarkar
Modified: 2012-03-12 15:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-05 16:20:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kedar Bidarkar 2012-03-02 14:20:37 EST
Description of problem:
2012-03-02 18:41:46,598 [ERROR][MainThread] create_redhat_repo() @ pulp_api.py:351 - Exception attempting to create Red Hat repository [rhel-x86_64-6-rhui-2-source-rpms-6Server-x86_64]
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/rhui/tools/pulp_api.py", line 337, in create_redhat_repo
    preserve_metadata=True)
  File "/usr/lib/python2.6/site-packages/pulp/client/api/repository.py", line 46, in create
    return self.server.PUT(path, repodata)[1]
  File "/usr/lib/python2.6/site-packages/pulp/client/api/server.py", line 326, in PUT
    return self._request('PUT', path, body=body)
  File "/usr/lib/python2.6/site-packages/pulp/client/api/server.py", line 287, in _request
    raise ServerRequestError(response.status, message, traceback)
ServerRequestError: (500, u"OSError: [Errno 13] Permission denied: '/etc/pki/content/rhel-x86_64-6-rhui-2-source-rpms-6Server-x86_64'", u'Traceback (most recent call last):\n  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/controllers/decorators.py", line 48, in report_error\n    return method(self, *args, **kwargs)\n  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/controllers/decorators.py", line 127, in _auth_decorator\n    value = method(self, *args, **kwargs)\n  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/controllers/repositories.py", line 333, in POST\n    publish=repo_data.get(\'publish\', None),)\n  File "/usr/lib/python2.6/site-packages/pulp/server/api/repo.py", line 278, in create\n    feed_cert_files = repo_cert_utils.write_feed_cert_bundle(id, feed_cert_data)\n  File "/usr/lib/python2.6/site-packages/pulp/repo_auth/repo_cert_utils.py", line 236, in write_feed_cert_bundle\n    return self._write_cert_bundle(\'feed-%s\' % repo_id, cert_dir, bundle or EMPTY_BUNDLE)\n  File "/usr/lib/python2.6/site-packages/pulp/repo_auth/repo_cert_utils.py", line 572, in _write_cert_bundle\n    os.makedirs(cert_dir)\n  File "/usr/lib64/python2.6/os.py", line 157, in makedirs\n    mkdir(name, mode)')


Version-Release number of selected component (if applicable):
RHUI 2.0.60

How reproducible:
Only after RHUI upgrade to 2.0.2 GOLD from 2.0.1 GOLD

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 wes hayutin 2012-03-04 19:22:42 EST
Kedar, please add more details to these bugs
1. commands used
2. attach relevant log files
3. cdn info
Comment 2 Kedar Bidarkar 2012-03-05 04:10:26 EST
Ah! sorry.

The RH repo creation fails via rhui-manager 
IT's regarding the addition of a new repo to RHUI.

home -> r -> a 

No relevant information related to this issue except the above extract from the
/var/log/pulp/cleint.log file.


Below log from /var/log/httpd/error_log  (now error_log-20120304)

[Fri Mar 02 18:41:46 2012] [error] 2012-03-02 18:41:46,596 pulp.server.webservices.controllers.decorators:ERROR: Traceback (most recent call last):
[Fri Mar 02 18:41:46 2012] [error]   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/controllers/decorators.py", line 48, in report_error
[Fri Mar 02 18:41:46 2012] [error]     return method(self, *args, **kwargs)
[Fri Mar 02 18:41:46 2012] [error]   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/controllers/decorators.py", line 127, in _auth_decorator
[Fri Mar 02 18:41:46 2012] [error]     value = method(self, *args, **kwargs)
[Fri Mar 02 18:41:46 2012] [error]   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/controllers/repositories.py", line 333, in POST
[Fri Mar 02 18:41:46 2012] [error]     publish=repo_data.get('publish', None),)
[Fri Mar 02 18:41:46 2012] [error]   File "/usr/lib/python2.6/site-packages/pulp/server/api/repo.py", line 278, in create
[Fri Mar 02 18:41:46 2012] [error]     feed_cert_files = repo_cert_utils.write_feed_cert_bundle(id, feed_cert_data)
[Fri Mar 02 18:41:46 2012] [error]   File "/usr/lib/python2.6/site-packages/pulp/repo_auth/repo_cert_utils.py", line 236, in write_feed_cert_bundle
[Fri Mar 02 18:41:46 2012] [error]     return self._write_cert_bundle('feed-%s' % repo_id, cert_dir, bundle or EMPTY_BUNDLE)
[Fri Mar 02 18:41:46 2012] [error]   File "/usr/lib/python2.6/site-packages/pulp/repo_auth/repo_cert_utils.py", line 572, in _write_cert_bundle
[Fri Mar 02 18:41:46 2012] [error]     os.makedirs(cert_dir)
[Fri Mar 02 18:41:46 2012] [error]   File "/usr/lib64/python2.6/os.py", line 157, in makedirs
[Fri Mar 02 18:41:46 2012] [error]     mkdir(name, mode)
[Fri Mar 02 18:41:46 2012] [error] OSError: [Errno 13] Permission denied: '/etc/pki/content/rhel-x86_64-6-rhui-2-source-rpms-6Server-x86_64'
[Fri Mar 02 18:41:46 2012] [error]


Tried via both staging and cdn.redhat.com , but nogo
Comment 3 James Slagle 2012-03-05 16:20:13 EST

*** This bug has been marked as a duplicate of bug 799497 ***
Comment 4 James Slagle 2012-03-05 16:20:26 EST

*** This bug has been marked as a duplicate of bug 799498 ***
Comment 5 James Slagle 2012-03-12 15:38:42 EDT
Released in RHUI 2.0.2
Comment 6 James Slagle 2012-03-12 15:44:18 EDT

*** This bug has been marked as a duplicate of bug 799497 ***

Note You need to log in before you can comment on or make changes to this bug.