Bug 799497 - Dependency issues during yum update[RHUI Upgrade]
Dependency issues during yum update[RHUI Upgrade]
Status: CLOSED CURRENTRELEASE
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.0.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jay Dobies
wes hayutin
:
: 799495 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-02 14:26 EST by Kedar Bidarkar
Modified: 2012-03-12 15:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-12 15:39:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kedar Bidarkar 2012-03-02 14:26:27 EST
Description of problem:

[root@xxxxxx yum.repos.d]# yum --disablerepo=* --enablerepo=rhui-rhel-x86_64-6-rhui-2-rpms update
Loaded plugins: product-id, pulp-profile-update, rhnplugin, rhui-lb,
              : subscription-manager
Updating Red Hat repositories.
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package gofer.noarch 0:0.43-1.el6 will be updated
---> Package gofer.noarch 0:0.64-1.el6 will be an update
---> Package grinder.noarch 0:0.0.122-1.el6 will be updated
---> Package grinder.noarch 0:0.0.136-1.el6 will be an update
---> Package m2crypto.x86_64 0:0.20.2-7.el6 will be updated
---> Package m2crypto.x86_64 0:0.21.1.pulp-7.el6 will be an update
---> Package mod_wsgi.x86_64 0:3.2-3.sslpatch.el6 will be updated
---> Package mod_wsgi.x86_64 0:3.3-2.pulp.el6 will be an update
---> Package mongodb.x86_64 0:1.6.4-3.el6_0 will be updated
--> Processing Dependency: libmongoclient.so()(64bit) for package: mongodb-1.8.2-2.el6.x86_64
---> Package mongodb.x86_64 0:1.8.2-2.el6 will be an update
---> Package mongodb-server.x86_64 0:1.6.4-3.el6_0 will be updated
---> Package mongodb-server.x86_64 0:1.8.2-2.el6 will be an update
---> Package pulp.noarch 0:0.0.214-8.el6 will be updated
---> Package pulp.noarch 0:0.0.263-11.el6 will be an update
--> Processing Dependency: pulp-selinux-server = 0.0.263 for package: pulp-0.0.263-11.el6.noarch
--> Processing Dependency: rh-rhua-selinux-policy for package: pulp-0.0.263-11.el6.noarch
---> Package pulp-admin.noarch 0:0.0.263-11.el6 will be obsoleting
---> Package pulp-client.noarch 0:0.0.214-8.el6 will be obsoleted
---> Package pulp-client-lib.noarch 0:0.0.263-11.el6 will be obsoleting
--> Processing Dependency: gofer-package >= 0.64 for package: pulp-client-lib-0.0.263-11.el6.noarch
---> Package pulp-common.noarch 0:0.0.214-8.el6 will be updated
---> Package pulp-common.noarch 0:0.0.263-11.el6 will be an update
---> Package pulp-consumer.noarch 0:0.0.263-11.el6 will be obsoleting
---> Package python-gofer.noarch 0:0.43-1.el6 will be updated
---> Package python-gofer.noarch 0:0.64-1.el6 will be an update
---> Package python-isodate.noarch 0:0.4.4-2.el6_1 will be updated
---> Package python-isodate.noarch 0:0.4.4-4.pulp.el6 will be an update
---> Package python-oauth2.noarch 0:1.2.1-3.el6_0 will be updated
---> Package python-oauth2.noarch 0:1.5.170-2.pulp.el6 will be an update
---> Package rh-rhui-tools.noarch 0:2.0.44-1.el6 will be updated
---> Package rh-rhui-tools.noarch 0:2.0.60-1.el6 will be an update
--> Running transaction check
---> Package gofer-package.noarch 0:0.64-1.el6 will be installed
---> Package libmongodb.x86_64 0:1.8.2-2.el6 will be installed
---> Package pulp-selinux-server.noarch 0:0.0.263-11.el6 will be installed
---> Package rh-rhua-selinux-policy.noarch 0:0.0.6-1.el6 will be installed
--> Processing Dependency: /usr/sbin/semanage for package: rh-rhua-selinux-policy-0.0.6-1.el6.noarch
--> Processing Dependency: /usr/sbin/semanage for package: rh-rhua-selinux-policy-0.0.6-1.el6.noarch
--> Finished Dependency Resolution
Error: Package: rh-rhua-selinux-policy-0.0.6-1.el6.noarch (rhui-rhel-x86_64-6-rhui-2-rpms)
           Requires: /usr/sbin/semanage
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Version-Release number of selected component (if applicable):


How reproducible:
yum --disablerepo=* --enablerepo=rhui-rhel-x86_64-6-rhui-2-rpms update

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 James Slagle 2012-03-05 16:20:13 EST
*** Bug 799495 has been marked as a duplicate of this bug. ***
Comment 2 James Slagle 2012-03-05 16:21:41 EST
This issue has been addressed in the release notes staged at https://engineering.redhat.com/trac/mgmt-integrated/wiki/cloude/rhui-202-release-notes

policycoreutils-python needs to be installed on the RHUA before running the yum update to update the rhui packages.
Comment 3 Kedar Bidarkar 2012-03-06 09:40:15 EST
yum install policycoreutils-python solves the issue.

Also added to the release notes.
Comment 4 James Slagle 2012-03-12 15:39:12 EDT
Released in RHUI 2.0.2
Comment 5 James Slagle 2012-03-12 15:44:18 EDT
*** Bug 799495 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.