Bug 799552 - R_PPC64_ADDR32 fff85e94858 for symbol `' out of range
R_PPC64_ADDR32 fff85e94858 for symbol `' out of range
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jack-audio-connection-kit (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orcan Ogetbil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-02 18:15 EST by Petr Machata
Modified: 2015-05-04 21:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-03 10:27:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A fix (771 bytes, patch)
2012-03-02 18:15 EST, Petr Machata
no flags Details | Diff

  None (edit)
Description Petr Machata 2012-03-02 18:15:46 EST
Created attachment 567187 [details]
A fix

Description of problem:
On ppc64, when starting mpd compiled against libjack, I'm getting the following error:

$ mpd
mpd: error while loading shared libraries: /usr/lib64/libjack.so.0: R_PPC64_ADDR32 fff85e94858 for symbol `' out of range

The problem seems to be that two label references need to be stored into two 32-bit field, while they need 64-bit field.  An attached patch fixes this in an obvious way.  I haven't checked that the impacted functionality (timers) works as expected, but at least now mpd on ppc64 starts and seems to be working well.
Comment 1 Orcan Ogetbil 2012-03-03 10:27:55 EST
Thanks for the patch. Applied in rawhide.

Note You need to log in before you can comment on or make changes to this bug.