Bug 799594 - running calendar shows fatal cpp error (liblto_plugin.so not found)
running calendar shows fatal cpp error (liblto_plugin.so not found)
Status: CLOSED DUPLICATE of bug 787345
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
16
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-03 04:58 EST by stadtkind2
Modified: 2012-03-29 16:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-29 16:11:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description stadtkind2 2012-03-03 04:58:05 EST
Description of problem:
Running calendar shows the following cpp error:
cpp: fatal error: -fuse-linker-plugin, but liblto_plugin.so not found

Version-Release number of selected component (if applicable):
calendar-1.26-3.20110531cvs.fc16.x86_64
cpp-4.6.2-1.fc16.x86_64

How reproducible:
happens every time (even with an empty calendar file); running cpp -E on a hello_world.c file is fine though

Steps to Reproduce:
1. echo "03/04 Testentry" > ~/testcal
2. calendar -f ~/testcal

Actual results:
cpp: fatal error: -fuse-linker-plugin, but liblto_plugin.so not found
compilation terminated.
Mar 04  Testentry

Expected results:
Mar 04  Testentry

Additional info:
Comment 1 David Cantrell 2012-03-21 13:09:13 EDT
I am unable to reproduce the issue on my local F-16 system:

$ echo "#include <calendar.usholidy>" > testcal
$ echo -e "03/22\tTestentry" >> testcal
$ calendar -f testcal
Mar 22  Testentry
$ rpm -q calendar
calendar-1.26-3.20110531cvs.fc16.x86_64
$ rpm -q cpp
cpp-4.6.2-1.fc16.x86_64
Comment 2 stadtkind2 2012-03-21 15:35:35 EDT
Just one question, do you have gcc installed?

$ rpm -qf /usr/libexec/gcc/x86_64-redhat-linux/4.6.2/liblto_plugin.so
gcc-4.6.2-1.fc16.x86_64
Comment 3 David Cantrell 2012-03-21 15:48:32 EDT
Yep:

[dcantrel@f16 ~]$ rpm -qf /usr/libexec/gcc/x86_64-redhat-linux/4.6.2/liblto_plugin.so
gcc-4.6.2-1.fc16.x86_64
Comment 4 stadtkind2 2012-03-21 15:59:54 EDT
Please try to reproduce the bug without having gcc installed (as there is no dependency on gcc when you install calendar).
Comment 5 David Cantrell 2012-03-21 16:17:38 EDT
OK, that did it.  Reassigning to gcc.  Either cpp shouldn't need liblto_plugin.so or it should depend on the gcc package.
Comment 6 Mitch Davis 2012-03-29 06:25:46 EDT
This is a dupe of bug 787345
Comment 7 David Cantrell 2012-03-29 16:11:07 EDT
So dupe it.

*** This bug has been marked as a duplicate of bug 787345 ***

Note You need to log in before you can comment on or make changes to this bug.