Bug 799616 - RHEL 6.X installation on IBM HS22 blade Type 7870 does not start
RHEL 6.X installation on IBM HS22 blade Type 7870 does not start
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drivers (Show other bugs)
6.2
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-03 10:36 EST by Tunca Karabel
Modified: 2012-05-21 17:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-21 17:18:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHEL Installation - green bars (24.71 KB, image/jpeg)
2012-03-05 16:47 EST, Tunca Karabel
no flags Details

  None (edit)
Description Tunca Karabel 2012-03-03 10:36:41 EST
Description of problem:

I cannot install RHEL 6.2 or 6.0 on HS22 blade Type 7870. See actual results section for installation problem.

I tried also the installation with basic video driver but got the same problem.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Start the RHEL 6.2 or 6.0 Installation from DVD on HS22 blade
2. 
3.
  
Actual results:

Without HS22 and AMM firmware update i get after installation menu (where i can select if i want to start with basic driver or normal) a screen with green bars, where i cannot continue the installation. See attachment. 

With HS22 and AMM firmware update(latest) i can even not see any installation menu. I see only after starting from cd 2 seconds the cursor in the left top corner and then the message:

No Video available

Your server may be in an unsupported resolution/refresh rate.


Expected results:

Installation should start like expected.

Additional info:

On some HS22 blades i could still install RHEL 6.2 but all blades have the same hardware. Some of these blades have even still the old firmware. 

Old HS22 Firmware:
  1   	  blade01   	  FW/BIOS   	  P9E124AUS       04/30/2009   1.02	
  1   	  blade01   	  Diagnostics     P9YT40A   	  03/13/2009   1.13
  1   	  dwa0601   	  Blade Sys    	  YUOO48F                      1.08
                          Mgmt Processor

New HS22 Firmware:
  1   	  blade01   	  FW/BIOS   	  P9E155B   	  12/14/2011   1.16	
  1   	  blade01   	  Diagnostics     DSYT89O   	  09/23/2011   3.48
  1   	  blade01   	  Blade Sys    	  YUOOC7F                      1.31
                          Mgmt Processor

Old AMM Firmware:
1   	  RACk3-AMM   	  AMM firmware  BPET50G CNETCMUS.PKT  10/30/2009  50

New AMM Firmware:
1   	  Standby MM   	  AMM firmware  BPET62F CNETCMUS.PKT  09/12/2011  62
Comment 2 Adam Jackson 2012-03-05 15:37:48 EST
(In reply to comment #0)

> Actual results:
> 
> Without HS22 and AMM firmware update i get after installation menu (where i can
> select if i want to start with basic driver or normal) a screen with green
> bars, where i cannot continue the installation. See attachment. 

The attachment seems not to have been attached.

What graphics hardware is this with?  If you try a text-mode install and switch to an alternate VT you should find a command prompt.  We would need the output of 'lspci -vnn | grep VGA'.

Alternatively you should be able to complete a VNC installation, after which you can ssh into the machine as usual.
Comment 3 Tunca Karabel 2012-03-05 16:47:18 EST
Created attachment 567768 [details]
RHEL Installation - green bars
Comment 4 Tunca Karabel 2012-03-05 17:08:00 EST
I added the screenshot now. 

Regarding the IBM page (http://publib.boulder.ibm.com/infocenter/bladectr/documentation/index.jsp?topic=/com.ibm.bladecenter.hs22.doc/bls_hs22_product_page.html) there is Integrated Matrox G200eV video controller in the HS22 blade.

How can i enter the text-mode installation? The installations is not coming to the screen where i can select any option.
Comment 5 Adam Jackson 2012-03-05 17:35:57 EST
The DVD should present you with a boot menu (I'm virtually certain; I usually install from our local PXE servers and haven't tried DVD media in ages).  If nothing else you should be able to hit Tab after exiting the BIOS part of boot to get a menu.

If you're not getting to that point I suspect your problem is with the firmware on the blade and not with RHEL.
Comment 6 Suzanne Yeghiayan 2012-03-07 16:28:42 EST
This request was evaluated by Red Hat Product Management for inclusion in the
current release of Red Hat Enterprise Linux. Because the affected component is
not scheduled to be updated in the current release, Red Hat is unfortunately
unable to address this request at this time.  It has been proposed for the next
release. If you would like it considered as an exception in the current
release, please ask your support representative.
Comment 7 Adam Jackson 2012-05-17 16:15:21 EDT
Reporter, are you still having issues with installation on this platform?
Comment 8 Tunca Karabel 2012-05-21 12:32:47 EDT
In the meantime i avoided the problem with the workaround from the Bug 591718 :
 
https://bugzilla.redhat.com/show_bug.cgi?id=591718#c10

where i disabled the setting "force legacy video mode" in the BIOS settings.

There stays also that a newer firmware level from IBM.com will solve the problem.
Comment 9 Adam Jackson 2012-05-21 17:18:31 EDT
Since this appears to be the same (firmware) issue as in bug #591718, I am closing this issue as NOTABUG as well.

Note You need to log in before you can comment on or make changes to this bug.