Bug 799625 - bridge-utils missing from DVD install
bridge-utils missing from DVD install
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
17
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-03 11:26 EST by Tom Horsley
Modified: 2014-03-16 23:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-05 14:50:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2012-03-03 11:26:49 EST
Description of problem:

I installed Fedora 17 Alpha x86_64 from the DVD media, included just about
everything in a custom config (except all the languages I can't understand
so there is no point in installing). Apparently none of that managed to
bring in bridge-utils (and in fact, I just checked, and bridge-utils is
not in the Packages directory on the DVD).

When I copied my ifcfg scripts to reproduce my complicated vlan and bridge
setup in the new fedora 17 partition, I was then left with no networking
at all and had to manually modify everything to keep the vlans and remove
the bridges in order to get networking to work long enough to install
bridge-utils.

It is only 29K, and it is vital for network configs that use a bridge.
Seems to me it ought to be included on the media.

Version-Release number of selected component (if applicable):
F17 alpha x86_64 DVD

How reproducible:
100% I'd imagine since it isn't on the DVD.

Steps to Reproduce:
1.Install f17
2.have to bridge support
3.
  
Actual results:
bridge don't work

Expected results:
bridge works

Additional info:
Comment 1 Andre Robatino 2012-03-03 11:47:52 EST
Missing on both the i386 and x86_64 17 Alpha DVDs. On my F16 box, "yum erase bridge-utils" only wants to remove libvirt. libvirt is on both the 16 Final and 17 Alpha DVDs, but bridge-utils is only on the 16 Final DVD. In F17, installing libvirt does NOT pull in bridge-utils.
Comment 2 Bill Nottingham 2012-03-05 14:50:24 EST
We don't necessarily include all possible networking requirements in the initscripts pacakge. For example, it doesn't require a dhcp client.

Given that, I've  changed comps so that bridge-utils is now a default package there.

Note You need to log in before you can comment on or make changes to this bug.