Bug 799629 - Multilib trouble with at-spi2-atk
Multilib trouble with at-spi2-atk
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: at-spi2-atk (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-03 12:18 EST by Arkady L. Shane
Modified: 2012-09-26 19:17 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-26 19:17:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arkady L. Shane 2012-03-03 12:18:37 EST
[root@jupiter ~]# LANG=C rpm -q at-spi2-atk-2.2.1-2.fc16.x86_64
at-spi2-atk-2.2.1-2.fc16.x86_64
[root@jupiter ~]# LANG=C yum -y install at-spi2-atk.i686
Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package at-spi2-atk.i686 0:2.2.1-2.fc16 will be installed
--> Processing Dependency: libatspi.so.0 for package: at-spi2-atk-2.2.1-2.fc16.i686
--> Processing Dependency: libatk-1.0.so.0 for package: at-spi2-atk-2.2.1-2.fc16.i686
--> Running transaction check
---> Package at-spi2-core.i686 0:2.2.1-2.fc16 will be installed
--> Processing Dependency: libXevie.so.1 for package: at-spi2-core-2.2.1-2.fc16.i686
---> Package atk.i686 0:2.2.0-2.fc16 will be installed
--> Running transaction check
---> Package libXevie.i686 0:1.0.3-2.fc15 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

===========================================================================================================================================
 Package                             Arch                        Version                               Repository                     Size
===========================================================================================================================================
Installing:
 at-spi2-atk                         i686                        2.2.1-2.fc16                          fedora                         89 k
Installing for dependencies:
 at-spi2-core                        i686                        2.2.1-2.fc16                          fedora                        135 k
 atk                                 i686                        2.2.0-2.fc16                          fedora                        221 k
 libXevie                            i686                        1.0.3-2.fc15                          fedora                         16 k

Transaction Summary
===========================================================================================================================================
Install       4 Packages

Total size: 461 k
Installed size: 461 k
Downloading Packages:
Running Transaction Check
Running Transaction Test


Transaction Check Error:
  file /usr/share/glib-2.0/schemas/org.a11y.atspi.gschema.xml from install of at-spi2-atk-2.2.1-2.fc16.i686 conflicts with file from package at-spi2-atk-2.2.1-2.fc16.x86_64

Error Summary
-------------
Comment 1 Philippe Troin 2012-06-12 18:04:38 EDT
Still present in at-spi2-atk-2.4.0-2.fc17:

yum -y install at-spi2-atk-2.4.0-2.fc17.i686
Loaded plugins: changelog, downloadonly, priorities, remove-with-leaves, show-
              : leaves, tsflags
16 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package at-spi2-atk.i686 0:2.4.0-2.fc17 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package              Arch          Version               Repository       Size
================================================================================
Installing:
 at-spi2-atk          i686          2.4.0-2.fc17          fedora           91 k

Transaction Summary
================================================================================
Install  1 Package

Total size: 91 k
Installed size: 425 k
Downloading Packages:
Running Transaction Check
Running Transaction Test


Transaction Check Error:
  file /usr/share/glib-2.0/schemas/org.a11y.atspi.gschema.xml from install of at-spi2-atk-2.4.0-2.fc17.i686 conflicts with file from package at-spi2-atk-2.4.0-2.fc17.x86_64

Error Summary
-------------

[2]    11828 exit 1     noglob yum -y install at-spi2-atk-2.4.0-2.fc17.i686
Comment 2 Jeffrey C. Ollie 2012-09-09 23:33:56 EDT
I've also noticed this problem with the Fedora 18 rpms, when trying a yum upgrade from F17 to F18.
Comment 3 Matthias Clasen 2012-09-26 19:15:55 EDT
Fixed in at-spi2-atk-2.5.91-2.fc18

Note You need to log in before you can comment on or make changes to this bug.