Bug 799644 - [abrt] libreoffice-core-3.4.5.2-6.fc16: pyuno::PyUNO_getattr: Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-3.4.5.2-6.fc16: pyuno::PyUNO_getattr: Process /usr/li...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:acbf2abed83b3cad59d432bdab3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-03 14:19 EST by Milan Bouchet-Valat
Modified: 2012-06-18 10:01 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-18 09:59:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (21.81 KB, text/plain)
2012-03-03 14:19 EST, Milan Bouchet-Valat
no flags Details
File: maps (88.86 KB, text/plain)
2012-03-03 14:19 EST, Milan Bouchet-Valat
no flags Details
File: build_ids (7.89 KB, text/plain)
2012-03-03 14:19 EST, Milan Bouchet-Valat
no flags Details
File: backtrace (94.04 KB, text/plain)
2012-03-03 14:19 EST, Milan Bouchet-Valat
no flags Details

  None (edit)
Description Milan Bouchet-Valat 2012-03-03 14:19:34 EST
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer file:///home/milan/.cache/.fr-unfsxS/Fichiers%20TXT%20nettoye%CC%81s%20et%20code%CC%81s/Culture-01Dec.txt.doc --splash-pipe=7
comment:        I just closed a text document, I didn't notice the crash.
crash_function: pyuno::PyUNO_getattr
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.2.3-2.fc16.x86_64
pid:            19745
pwd:            /home/milan
reason:         Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
time:           sam. 03 mars 2012 18:25:55 CET
uid:            1000
username:       milan

backtrace:      Text file, 96295 bytes
build_ids:      Text file, 8077 bytes
dso_list:       Text file, 22329 bytes
maps:           Text file, 90996 bytes

environ:
:XDG_VTNR=7
:XDG_SESSION_ID=120
:HOSTNAME=milan
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GIO_LAUNCHED_DESKTOP_FILE_PID=19733
:GPG_AGENT_INFO=/tmp/keyring-x9GMlB/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:DESKTOP_STARTUP_ID=file-roller-19725-milan-libreoffice-0_TIME411755926
:HISTSIZE=1000
:XDG_SESSION_COOKIE=9e1782da896cc13ddd95ca060000000c-1330776625.485616-797847102
:GJS_DEBUG_OUTPUT=stderr
:OLDPWD=/usr/lib64/libreoffice/program
:GNOME_KEYRING_CONTROL=/tmp/keyring-x9GMlB
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:USER=milan
:SSH_AUTH_SOCK=/tmp/keyring-x9GMlB/ssh
:USERNAME=milan
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/27477,unix/unix:/tmp/.ICE-unix/27477
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/libreoffice-writer.desktop
:MAIL=/var/spool/mail/milan
:PATH=/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/milan
:XMODIFIERS=@im=none
:KDE_IS_PRELINKED=1
:GNOME_KEYRING_PID=27470
:LANG=fr_FR.utf8
:GDM_LANG=fr_FR.utf8
:KDEDIRS=/usr/local:/usr
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/milan
:XDG_SEAT=seat0
:SHLVL=1
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=milan
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-brZuI343BG,guid=7f7c802200849512bc67e43d0005fec2
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=7
:XDG_RUNTIME_DIR=/run/user/milan
:DISPLAY=:0.0
:CCACHE_HASHDIR=
:XAUTHORITY=/var/run/gdm/auth-for-milan-AjXjLf/database
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/client:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/native_threads:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64

var_log_messages:
:Mar  3 18:25:55 milan kernel: [411114.266094] soffice.bin[19761]: segfault at 0 ip 00007f695232ae4e sp 00007f695968f260 error 4 in libpyuno.so[7f6952314000+2f000]
:Mar  3 18:25:56 milan abrt[19796]: Saved core dump of pid 19745 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-03-03-18:25:55-19745 (141344768 bytes)
Comment 1 Milan Bouchet-Valat 2012-03-03 14:19:38 EST
Created attachment 567324 [details]
File: dso_list
Comment 2 Milan Bouchet-Valat 2012-03-03 14:19:41 EST
Created attachment 567325 [details]
File: maps
Comment 3 Milan Bouchet-Valat 2012-03-03 14:19:43 EST
Created attachment 567326 [details]
File: build_ids
Comment 4 Milan Bouchet-Valat 2012-03-03 14:19:45 EST
Created attachment 567327 [details]
File: backtrace
Comment 5 Caolan McNamara 2012-03-05 09:35:27 EST
do you have any LibreOffice python extensions like lightproof or something of that nature ?
Comment 6 Milan Bouchet-Valat 2012-03-05 10:23:16 EST
Yeah, I'm using Grammalecte, which is a French grammar-checker based on Lightproof. Is it the culprit?
Comment 7 Caolan McNamara 2012-03-06 07:08:41 EST
possibly the trigger, probably not its fault, but good to know what python extensions are installed when trying to reproduce the problem.
Comment 8 Stephan Bergmann 2012-06-18 09:59:51 EDT
From the attachment 567327 [details] backtrace (GrammarCheckingIterator thread still running as thread 1 during desktop::Desktop::DeInit in thread 6), this looks like addressed by upstream <http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-5-5&id=69ba498b4cfd2b25ddc1c84f83d376d11c321fce> "Properly join spawned GrammarCheckingIterator thread."  That fix will go into upcoming LibreOffice 3.5.5, which should find its way into Fedora 17.
Comment 9 Stephan Bergmann 2012-06-18 10:01:34 EDT
(In reply to comment #8)
> That fix will go into upcoming LibreOffice
> 3.5.5, which should find its way into Fedora 17.

Actually, that fix is already in upstream LibreOffice 3.5.4, so already available in Fedora 17.

Note You need to log in before you can comment on or make changes to this bug.