Bug 799736 - https tracker crash in lt 0.15.8
https tracker crash in lt 0.15.8
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rb_libtorrent (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
abrt_hash:03f27986ba9f38d27502bf689cd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-04 15:25 EST by spam.hhein
Modified: 2012-05-03 03:28 EDT (History)
4 users (show)

See Also:
Fixed In Version: rb_libtorrent-0.15.9-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-20 15:47:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (17.07 KB, text/plain)
2012-03-04 15:25 EST, spam.hhein
no flags Details
File: build_ids (6.85 KB, text/plain)
2012-03-04 15:25 EST, spam.hhein
no flags Details
File: maps (75.16 KB, text/plain)
2012-03-04 15:26 EST, spam.hhein
no flags Details
File: backtrace (165.82 KB, text/plain)
2012-03-04 15:26 EST, spam.hhein
no flags Details

  None (edit)
Description spam.hhein 2012-03-04 15:25:42 EST
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/bin/python /usr/bin/deluge-gtk
comment:        Opened settings. When accepting the new settings, deluge crashed.
executable:     /usr/bin/python
kernel:         3.2.7-1.fc16.x86_64
pid:            3579
pwd:            /home/s
reason:         Process /usr/bin/python was killed by signal 11 (SIGSEGV)
time:           Sun 04 Mar 2012 08:55:53 PM CET
uid:            1000
username:       s

backtrace:      Text file, 169796 bytes
build_ids:      Text file, 7011 bytes
dso_list:       Text file, 17477 bytes
maps:           Text file, 76962 bytes

environ:
:XDG_VTNR=1
:LDFLAGS=-L/opt/gtk/lib
:XDG_SESSION_ID=2
:HOSTNAME=minibld
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/tmp/keyring-976YJ0/gpg:0:1
:TERM=xterm
:SHELL=/bin/bash
:HISTSIZE=1000
:XDG_SESSION_COOKIE=7aaced1a5f39849f5bf6cf7600000006-1330887555.874968-1213478959
:CPPFLAGS=-I/opt/gtk/include
:GJS_DEBUG_OUTPUT=stderr
:WINDOWID=52428806
:GNOME_KEYRING_CONTROL=/tmp/keyring-976YJ0
:QTDIR=/usr/lib64/qt-3.3
:QTINC=/usr/lib64/qt-3.3/include
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:USER=s
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:*.pdf=00;33:*.ps=00;33:*.ps.gz=00;33:*.txt=00;33:*.patch=00;33:*.diff=00;33:*.log=00;33:*.tex=00;33:*.xls=00;33:*.xlsx=00;33:*.ppt=00;33:*.pptx=00;33:*.rtf=00;33:*.doc=00;33:*.docx=00;33:*.odt=00;33:*.ods=00;33:*.odp=00;33:*.xml=00;33:*.epub=00;33:*.abw=00;33:*.html=00;33:*.wpd=00;33:
:SSH_AUTH_SOCK=/tmp/keyring-976YJ0/ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1556,unix/unix:/tmp/.ICE-unix/1556
:USERNAME=s
:PATH=/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/s/go/bin:/opt/gtk/lib:/home/s/.local/bin:/home/s/bin:/home/s/go/bin:/opt/gtk/lib
:MAIL=/var/spool/mail/s
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/s
:XMODIFIERS=@im=none
:EDITOR=nano
:GNOME_KEYRING_PID=1550
:LANG=en_US.utf8
:KDE_IS_PRELINKED=1
:GDM_LANG=en_US.utf8
:KDEDIRS=/usr
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/s
:SHLVL=2
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:LOGNAME=s
:QTLIB=/usr/lib64/qt-3.3/lib
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-8Jq1AIt72b,guid=7bac564a3d89dce3b0e8880400000039
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:PKG_CONFIG_PATH=/opt/gtk/lib/pkgconfig
:WINDOWPATH=1
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/s
:COLORTERM=gnome-terminal
:XAUTHORITY=/var/run/gdm/auth-for-s-jZUXOH/database
:_=/usr/bin/deluge-gtk

var_log_messages:
:Mar  4 20:52:20 minibld yum[3489]: Installed: gnome-python2-bonobo-2.28.1-7.fc16.x86_64
:Mar  4 20:52:20 minibld yum[3489]: Installed: boost-python-1.47.0-6.fc16.x86_64
:Mar  4 20:52:20 minibld yum[3489]: Installed: rb_libtorrent-python-0.15.8-1.fc16.x86_64
:Mar  4 20:52:24 minibld yum[3489]: Installed: gnome-python2-gnomevfs-2.28.1-7.fc16.x86_64
:Mar  4 20:52:24 minibld yum[3489]: Installed: gnome-python2-gnome-2.28.1-7.fc16.x86_64
:Mar  4 20:55:54 minibld abrt[3618]: Saved core dump of pid 3579 (/usr/bin/python) to /var/spool/abrt/ccpp-2012-03-04-20:55:53-3579 (97484800 bytes)
Comment 1 spam.hhein 2012-03-04 15:25:50 EST
Created attachment 567409 [details]
File: dso_list
Comment 2 spam.hhein 2012-03-04 15:25:55 EST
Created attachment 567410 [details]
File: build_ids
Comment 3 spam.hhein 2012-03-04 15:26:11 EST
Created attachment 567411 [details]
File: maps
Comment 4 spam.hhein 2012-03-04 15:26:35 EST
Created attachment 567412 [details]
File: backtrace
Comment 5 Calum 2012-03-04 18:16:49 EST
This looks like a libtorrent https crash which has been fixed in 0.15.9.
Comment 6 Calum 2012-03-20 15:47:38 EDT

*** This bug has been marked as a duplicate of bug 805169 ***
Comment 7 Fedora Update System 2012-03-20 17:15:55 EDT
rb_libtorrent-0.15.9-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/rb_libtorrent-0.15.9-1.fc15
Comment 8 Fedora Update System 2012-03-20 17:17:06 EDT
rb_libtorrent-0.15.9-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/rb_libtorrent-0.15.9-1.fc17
Comment 9 Fedora Update System 2012-03-20 17:18:22 EDT
rb_libtorrent-0.15.9-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/rb_libtorrent-0.15.9-1.fc16
Comment 10 leigh scott 2012-03-28 08:26:02 EDT
rb_libtorrent-0.15.9-1 will stay in updates-testing forever unless karma is received.
Comment 11 Fedora Update System 2012-05-02 16:52:45 EDT
rb_libtorrent-0.15.9-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-05-03 03:28:50 EDT
rb_libtorrent-0.15.9-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.