Bug 799743 - SELinux is preventing /usr/libexec/gstreamer-0.10/gst-plugin-scanner from 'create' accesses on the None .gstreamer-0.10.
SELinux is preventing /usr/libexec/gstreamer-0.10/gst-plugin-scanner from 'cr...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:470d700ce7302096f8fa0feab5c...
: Reopened
: 799773 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-04 16:48 EST by david.p.risley
Modified: 2012-03-21 14:54 EDT (History)
4 users (show)

See Also:
Fixed In Version: selinux-policy-3.10.0-104.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-21 14:54:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description david.p.risley 2012-03-04 16:48:10 EST
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-0.rc3.git7.2.fc17.x86_64
reason:         SELinux is preventing /usr/libexec/gstreamer-0.10/gst-plugin-scanner from 'create' accesses on the None .gstreamer-0.10.
time:           Sun 04 Mar 2012 10:47:55 AM EST

description:
:SELinux is preventing /usr/libexec/gstreamer-0.10/gst-plugin-scanner from 'create' accesses on the None .gstreamer-0.10.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that gst-plugin-scanner should be allowed create access on the .gstreamer-0.10 <Unknown> by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep gst-plugin-scan /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:user_home_dir_t:s0
:Target Objects                .gstreamer-0.10 [ None ]
:Source                        gst-plugin-scan
:Source Path                   /usr/libexec/gstreamer-0.10/gst-plugin-scanner
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           totem-mozplugin-3.3.4-3.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-89.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed)
:                              3.3.0-0.rc3.git7.2.fc17.x86_64 #1 SMP Fri Feb 17
:                              18:55:53 UTC 2012 x86_64 x86_64
:Alert Count                   9
:First Seen                    Sun 04 Mar 2012 10:40:54 AM EST
:Last Seen                     Sun 04 Mar 2012 10:45:43 AM EST
:Local ID                      02a7d080-c994-4895-9816-d68e7b69e782
:
:Raw Audit Messages
:type=AVC msg=audit(1330875943.669:70): avc:  denied  { create } for  pid=1666 comm="totem-plugin-vi" name=".gstreamer-0.10" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=dirnode=(removed) type=SYSCALL msg=audit(1330875943.669:70): arch=c000003e syscall=83 success=no exit=-13 a0=23f15d0 a1=1ff a2=2 a3=7fff2c9f7400 items=0 ppid=1 pid=1666 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=1 comm="totem-plugin-vi" exe="/usr/libexec/totem-plugin-viewer" subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:
:Hash: gst-plugin-scan,mozilla_plugin_t,user_home_dir_t,None,create
:
:audit2allow
:
:
:audit2allow -R
:
:
Comment 1 Miroslav Grepl 2012-03-05 04:31:04 EST
*** Bug 799773 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2012-03-05 04:33:41 EST
Your homedir is mislabeled. Execute 

$ restorecon -R -v ~/
Comment 3 Adam Williamson 2012-03-16 18:43:39 EDT
I just hit this on clean boot of a freshly-built live image, using the latest updates-testing packages, after running Firefox and browsing to youtube.com. If the live user's home directory is mislabelled out of the box, we have a problem.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Adam Williamson 2012-03-16 18:45:07 EDT
Mar 19 18:41:31 localhost dbus[874]: avc:  denied  { acquire_svc } for service=org.gnome.totem.PluginViewer_1477 spid=1477 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_dbusd_t:s0-s0:c0.c1023 tclass=dbus
Mar 19 18:41:32 localhost setroubleshoot: SELinux is preventing /usr/libexec/totem-plugin-viewer from create access on the directory .gstreamer-0.10. For complete SELinux messages. run sealert -l 1e437d1b-2967-44ac-a7d8-49f525cbc736

is what's in /var/log/messages .
Comment 5 Adam Williamson 2012-03-16 18:46:27 EDT
SELinux is preventing /usr/libexec/totem-plugin-viewer from create access on the directory .gstreamer-0.10.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that totem-plugin-viewer should be allowed create access on the .gstreamer-0.10 directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep totem-plugin-vi /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp


Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:object_r:user_home_dir_t:s0
Target Objects                .gstreamer-0.10 [ dir ]
Source                        totem-plugin-vi
Source Path                   /usr/libexec/totem-plugin-viewer
Port                          <Unknown>
Host                          localhost.localdomain
Source RPM Packages           totem-mozplugin-3.3.90-2.fc17.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.10.0-95.fc17.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     localhost.localdomain
Platform                      Linux localhost.localdomain
                              3.3.0-0.rc7.git0.3.fc17.x86_64 #1 SMP Mon Mar 12
                              18:40:17 UTC 2012 x86_64 x86_64
Alert Count                   1
First Seen                    Mon 19 Mar 2012 06:41:31 PM EDT
Last Seen                     Mon 19 Mar 2012 06:41:31 PM EDT
Local ID                      1e437d1b-2967-44ac-a7d8-49f525cbc736

Raw Audit Messages
type=AVC msg=audit(1332196891.852:72): avc:  denied  { create } for  pid=1477 comm="totem-plugin-vi" name=".gstreamer-0.10" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=dir


type=SYSCALL msg=audit(1332196891.852:72): arch=x86_64 syscall=mkdir success=no exit=EACCES a0=164d730 a1=1ff a2=2 a3=7fffb9523490 items=0 ppid=1 pid=1477 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=1 comm=totem-plugin-vi exe=/usr/libexec/totem-plugin-viewer subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)

Hash: totem-plugin-vi,mozilla_plugin_t,user_home_dir_t,dir,create

audit2allow

#============= mozilla_plugin_t ==============
allow mozilla_plugin_t user_home_dir_t:dir create;

audit2allow -R

#============= mozilla_plugin_t ==============
allow mozilla_plugin_t user_home_dir_t:dir create;
Comment 6 Daniel Walsh 2012-03-17 06:44:25 EDT
Ok lets add 	gnome_filetrans_home_content(mozilla_plugin_t)

Which will fix the 

allow mozilla_plugin_t user_home_dir_t:dir create;

I will allow the plugin to acquire the dbus session bus service, although this makes me a bit nervous,  We really need to start turning on a mechanism to verify which domains are able to connect to which dbus services.

Fixed in selinux-policy-3.10.0-103.fc17
Comment 7 Fedora Update System 2012-03-19 13:55:30 EDT
selinux-policy-3.10.0-103.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-103.fc17
Comment 8 Fedora Update System 2012-03-20 02:08:34 EDT
Package selinux-policy-3.10.0-104.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-104.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4248/selinux-policy-3.10.0-104.fc17
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-03-21 14:54:26 EDT
selinux-policy-3.10.0-104.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.