Bug 799765 - samba-swat does NOT allow logins
samba-swat does NOT allow logins
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
17
i686 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Guenther Deschner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-04 19:14 EST by Barry Godusky
Modified: 2013-02-11 07:42 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-11 07:42:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
samba log file (847 bytes, text/plain)
2012-03-04 19:14 EST, Barry Godusky
no flags Details

  None (edit)
Description Barry Godusky 2012-03-04 19:14:05 EST
Created attachment 567435 [details]
samba log file

Description of problem:
Samba-swat will not allow logins after enabling xinet.d/swat and rebooting. The firewall is open for all samba programs and port 901 is also open.

Version-Release number of selected component (if applicable):
Name        : samba-swat
Arch        : i686
Epoch       : 1
Version     : 3.6.3
Release     : 78.fc17.1
Size        : 12 M
Repo        : installed
From repo   : fedora
Summary     : The Samba SMB server Web configuration program
URL         : http://www.samba.org/
License     : GPLv3+ and LGPLv3+
Description : The samba-swat package includes the new SWAT (Samba Web Administration
            : Tool), for remotely managing Samba's smb.conf file using         your favorite Web browser.


How reproducible:
Open a web browser(I use Firefox (10.0.1) type in 127.0.0.1:901. Attempt to log in, login dialog disappears when clicking OK and after a short period of time reappears asking for the user ID and password again without showing any errors at all.

Steps to Reproduce:
1.Open firefox
2.type in 127.0.0.1:901
3.type in user IS and password in login dialog
  
Actual results:
Login dialog disappears for a couple of seconds and reappears!

Expected results:
Log into the web based samba administration GUI.

Additional info:
Comment 1 Andreas Schneider 2013-01-30 04:43:51 EST
Please post your smb.conf file and make sure you have /etc/pam.d/samba.
Comment 2 Barry Godusky 2013-02-07 19:35:26 EST
I don't know if this was ever fixed in Fedora. I moved to ARCH when samba didn't work as intended, so I thought I'd report it.
I have the exact configuration in ARCH that I was going to use in Fedora and have no problems what so ever.

Sorry, guess I should have requested this bug to be closed since I don't use Fedora anymore.

So this bug can be closed.

Note You need to log in before you can comment on or make changes to this bug.