Bug 799770 - app windows appear torn when KDE desktop effects are turned on
app windows appear torn when KDE desktop effects are turned on
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kde-workspace (Show other bugs)
17
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-04 19:45 EST by Barry Godusky
Modified: 2012-05-31 08:49 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-31 08:49:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Ksnap of Kinfo graphic information (363.28 KB, application/x-gzip)
2012-03-04 19:45 EST, Barry Godusky
no flags Details

  None (edit)
Description Barry Godusky 2012-03-04 19:45:27 EST
Created attachment 567438 [details]
Ksnap of Kinfo graphic information

Description of problem:
KDE Desktop effects. KDE SC Ver: 4.8.00

The tittle bar and the bottom of app. windows are out of sink or torn from the main app. window when KDE's desktop effects are turned on. When desktop effects are turned off or xrender is used the app. windows appear normally.


Version-Release number of selected component (if applicable):
KDE SC 4.8.00

How reproducible:
Turn on desktop effects by setting in the system setting applet and using alt+shift+F12 keys.

Steps to Reproduce:
1.Set desktop effects on.
2.click apply
3.
  
Actual results:
desktop effects turn on but  app tittle bar and bottom is torn(not in sync) with the main app window

Expected results:
app windows to be in sync and aligned throughout the entire perimeter of app window.

Additional info:
Comment 1 Barry Godusky 2012-03-04 19:49:46 EST
My system is a Toshiba A75 S2112 laptop
ATI Radeon Mobility 9100IGP graphics
2Gb of memory

If needed I'll send a smolt file if you tell me how to retrieve it.
Comment 2 Martin Bříza 2012-04-26 06:40:45 EDT
You can retrieve your Smolt profile by using smoltSendProfile command, the application should be included in Fedora by default. But I'm not sure if it would help in this situation.

It's been a while since you filed this report (I'm sorry for answering this late) so I suppose there was a newer version of KDE SC released. Have you updated the system? Is this issue still present?
Also, have you tried changing effects settings in System Settings -> Desktop Effects -> Advanced?
I see you are using the radeon driver (i hope this is the open one) for your graphics adapter. Have you tried fglrx (proprietary one, official by ATI/AMD)? However, if you haven't, I wouldn't recommend that, as its installation is quite complicated and can cause other issues.
Comment 3 Barry Godusky 2012-04-26 09:46:40 EDT
This problem has resolved itself through some system updates. I was using the open radeon driver and have since switched back to the mesa drivers which seem to have corrected the problem. I gave up on the propriety drivers back at F14 because they were more trouble then they were worth. Even with the mesa drivers I has this problem but as I said the problem seems to have been corrected in one of the updates.
So you can close this bug report if you wish.
Comment 4 Martin Bříza 2012-05-31 08:49:19 EDT
Thank you for the report.
I'm closing the bug. Feel free to reopen if the issue appears again.

Note You need to log in before you can comment on or make changes to this bug.