Bug 799773 - SELinux is preventing /usr/libexec/totem-plugin-viewer from 'create' accesses on the directory .gstreamer-0.10.
SELinux is preventing /usr/libexec/totem-plugin-viewer from 'create' accesses...
Status: CLOSED DUPLICATE of bug 799743
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:d21a994661f7e7b579ff3f74a9a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-04 19:49 EST by david.p.risley
Modified: 2012-03-05 04:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-05 04:31:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description david.p.risley 2012-03-04 19:49:44 EST
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-0.rc5.git3.1.fc17.x86_64
reason:         SELinux is preventing /usr/libexec/totem-plugin-viewer from 'create' accesses on the directory .gstreamer-0.10.
time:           Sun 04 Mar 2012 06:49:32 PM CST

description:
:SELinux is preventing /usr/libexec/totem-plugin-viewer from 'create' accesses on the directory .gstreamer-0.10.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that totem-plugin-viewer should be allowed create access on the .gstreamer-0.10 directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep totem-plugin-vi /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:user_home_dir_t:s0
:Target Objects                .gstreamer-0.10 [ dir ]
:Source                        totem-plugin-vi
:Source Path                   /usr/libexec/totem-plugin-viewer
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           totem-mozplugin-3.3.4-3.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-95.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-0.rc5.git3.1.fc17.x86_64 #1
:                              SMP Wed Feb 29 21:22:11 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Sun 04 Mar 2012 06:48:11 PM CST
:Last Seen                     Sun 04 Mar 2012 06:48:11 PM CST
:Local ID                      f6f2c7d8-d844-43b1-a0a1-4588cfcb3327
:
:Raw Audit Messages
:type=AVC msg=audit(1330908491.188:62): avc:  denied  { create } for  pid=1471 comm="totem-plugin-vi" name=".gstreamer-0.10" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1330908491.188:62): arch=x86_64 syscall=mkdir success=no exit=EACCES a0=1920ef0 a1=1ff a2=2 a3=1c items=0 ppid=1 pid=1471 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=totem-plugin-vi exe=/usr/libexec/totem-plugin-viewer subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: totem-plugin-vi,mozilla_plugin_t,user_home_dir_t,dir,create
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-03-05 04:31:04 EST

*** This bug has been marked as a duplicate of bug 799743 ***

Note You need to log in before you can comment on or make changes to this bug.